Subsequence POJ - 3061 (二分法和尺取法两种做法)

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

二分法O(n*logn):枚举左区间,二分搜索右区间,也就是说右区间应该尽量往左靠

import java.util.Scanner;

public class Main 
{
    static int k,a[];
    public static void main(String[]args)
    {
        Scanner sc=new Scanner(System.in);
        int t=sc.nextInt();
        while((t--)>0)
        {
            int n=sc.nextInt();
            int s=sc.nextInt();
            int a[]=new int[n+1];
            int sum[]=new int[n+1];
            for(int i=1;i<=n;i++)
            {
                a[i]=sc.nextInt();
                sum[i]=sum[i-1]+a[i];//小技巧,使得求区间和的时间为O(1)
            }
            if(sum[n]0);
                continue;
            }
            if(sum[n]==s)//题设要求
            {
                System.out.println(n);
                continue;
            }
            int ans=n;
            for(int i=1;i<=n;i++ )//枚举左端点
            {
                if(sum[n]-sum[i-1]continue;//这种情况就不可能有答案
                int l=i;
                int r=n;
                while(l<=r)//二分找右区间
                {
                    int m=(l+r)/2;
                    if(sum[m]-sum[i-1]>=s)
                        r=m-1;
                    else
                        l=m+1;
                }
                r+=1;
                ans=Math.min(ans, r-i+1);//更新
            }
            System.out.println(ans);

        }
    }
}

尺取法O(n):
1.初始化左端和右端为0即l=r=0;
2.如果区间lr的和小于s,则r++;
反之 更新ans=min(ans,r-l+1);
3.重复2步骤,直到r==n,且此时区间lr的和小于s时,终止。

import java.util.Scanner;

public class Main 
{

    public static void main(String[]args)
    {
        Scanner sc=new Scanner(System.in);
        int t=sc.nextInt();
        while((t--)>0)
        {
            int n=sc.nextInt();
            int k=sc.nextInt();
            int a[]=new int[n+1];
            int sum[]=new int [n+1];
            for(int i=1;i<=n;i++)
            {
                a[i]=sc.nextInt();
                sum[i]=sum[i-1]+a[i];
            }
            if(sum[n]out.println(0);
                continue;
            }
            if(sum[n]==k)
            {
                System.out.println(n);
                continue;
            }
            int ans=n;
            int l=1,r=1;//初始化
            for(;;)
            {
                if(sum[r]-sum[l-1]if(r==n)
                        break;//终止情况
                    else
                        r++;否则右区间加一
                }
                else
                {
                    ans=Math.min(ans, r-l+1);//更新
                    l++;//然后右移区间左端
                }
            }
            System.out.println(ans);
        }
    }
}

你可能感兴趣的:(二分,尺取法)