fjnu 1039 Financial Management

 

Description

Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

 
  

 

Sample Output

 
  
 
  
 
  
Source:#include < iostream >
using   namespace  std;

float  a[ 13 ];

float  average()
{
    
float t=0;
    
for(int i=1;i<=12;i++)
        t
+=a[i];
    
return t/12;
}


int  main()
{
//    freopen("fjnu_1039.txt","r",stdin);
    for(int i=1;i<=12;i++)
    
{
        cin
>>a[i];
    }

    cout
<<"___FCKpd___3quot;;
    printf("%.2f ",average());
}

 

你可能感兴趣的:(output,iostream,float,input,each,☆ACM,解题报告☆)