PAT 乙级 1042 统计字符个数

  1. 字符统计(20)
    输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7

import java.util.Scanner;

/**
 * Created by lenovo on 2018/4/22.
 */
public class P1042New {
    public static void main(String[] args) {
        int[] count = new int[26]; 
        for (int i = 0; i < 26; i++) {
            count[i] = 0;
        }
        Scanner sc = new Scanner(System.in);
        String s = sc.nextLine();
        char[] chars = s.toCharArray();
        for (char c : chars) {
            if (c >= 'a' && c <= 'z') {
                count[c - 'a']++;
            } else if (c >= 'A' && c <= 'Z') {
                count[c - 'A']++;
            }
        }
        int maxCount = 0;
        int index = -1;
        for (int i = 0; i < 26; i++) {
            if (count[i] > maxCount) {
                maxCount = count[i];
                index = i;
            }
        }
        System.out.println((char) (index + 'a') + " " + maxCount);
    }
}

你可能感兴趣的:(PAT 乙级 1042 统计字符个数)