PAT 1113 Integer Set Partition python解法

1113 Integer Set Partition (25 分)
Given a set of N (>1) positive integers, you are supposed to partition them into two disjoint sets A​1 and A​2​​ of n​1​​ and n​2 numbers, respectively. Let S​1​​ and S​2​​ denote the sums of all the numbers in A​1​​ and A​2​​ , respectively. You are supposed to make the partition so that ∣n​1​​ −n​2​​ ∣ is minimized first, and then ∣S​1​​ −S​2​​ ∣ is maximized.
Input Specification:
Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤10​5​​ ), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2​31​​ .

Output Specification:
For each case, print in a line two numbers: ∣n​1​​ −n​2​​ ∣ and ∣S​1​​ −S​2​​ ∣, separated by exactly one space.

Sample Input 1:
10
23 8 10 99 46 2333 46 1 666 555
Sample Output 1:
0 3611
Sample Input 2:
13
110 79 218 69 3721 100 29 135 2 6 13 5188 85
Sample Output 2:
1 9359

解题思路:先将数字排序,然后切成两半,用后一半减前一半。

n = int(input())
l = list(map(int,input().split()))
#n = 13
#l =[110, 79, 218, 69, 3721, 100, 29, 135, 2, 6, 13, 5188, 85]
l.sort()
#l1 = l[:n//2]
#l2 = l[n//2:n]
#s1 = sum(l1)
#s2 = sum(l2)
#print(len(l2)-len(l1),s2-s1)
print(len(l[n//2:n])-len(l[:n//2]),sum(l[n//2:n])-sum(l[:n//2]))

你可能感兴趣的:(python,用Python刷PAT,(Advanced,Level),Practice)