PAT 1120 Friend Numbers python解法

1120 Friend Numbers (20 分)
Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID’s among them.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10^​4​​ .

Output Specification:
For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:
8
123 899 51 998 27 33 36 12
Sample Output:
4
3 6 9 26

解题思路:把每一个数的每一位加起来就是这个数的 frind ID,把每个数的 frind ID保存到列表中,然后将列表转换成集合再转换回列表,达到去重的目的,最后排序输出。

n = int(input())
l = list(map(str, input().split()))
friend = []
s = 0
for i in range(n):
    for j in range(len(l[i])):
        s += int(l[i][j])
    friend.append(s)
    s = 0

friend = list(set(friend))
friend.sort()
print(len(friend))
friend = [str(i) for i in friend]
print(' '.join(friend))

你可能感兴趣的:(python,用Python刷PAT,(Advanced,Level),Practice)