PAT 1063 Set Similarity python解法

1063 Set Similarity (25 分)
Given two sets of integers, the similarity of the sets is defined to be N​c/N​t×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:
Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​ ) and followed by M integers in the range [0,10​9​​ ]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%

题意:计算两个集合的相似度,相似度=N​c/N​t×100%,N​c是两个集合交集的元素个数,N​t是两个集合并集的元素个数。
解题思路:第一想法是使用set自带的intersection()和union(),把它们两个的长度一除就完事了,想法没错,但很耗时,最后一个测试点超时了。然后想到我们其实只需要并集的长度,而并集的长度=集合a的长度+集合b的长度-交集的长度,这样避开了求并集,节省了很多时间。

n = int(input())
l = []
for i in range(n):
    l.append(input().split()) 
#a = ['3', '99', '87', '101']
#b = ['4', '87', '101', '5', '87']
#b = ['7', '99', '101', '18', '5', '135', '18', '99']
def Similarity(a,b):
    a = set(a[1:])
    b = set(b[1:])
    nc = len(a.intersection(b))
    nt = len(a)+len(b)-nc
#   nt = len(a.union(b))
    return str(round(nc*100/nt,1))
#print(Similarity(a,b)+'%')            
k = int(input())
for i in range(k):
    a,b = map(int,input().split())
    print(Similarity(l[a-1],l[b-1])+'%')

你可能感兴趣的:(python,用Python刷PAT,(Advanced,Level),Practice)