PAT 1035 Password python解法

1035 Password (20 分)
To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 R@spodfa
Sample Input 2:
1
team110 abcdefg332
Sample Output 2:
There is 1 account and no account is modified
Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:
There are 2 accounts and no account is modified

题意:简单来说,就是替换字符,将[‘0’, ‘1’, ‘l’, ‘O’]分别替换成 [’%’, ‘@’,‘L’, ‘o’],需要注意的点是:1.只输出发生替换行为的字符串。2.如果没有发生任何替换行为,需要输出一句提示语,这句提示语要根据输出的字符串个数进行单复数的变动。

解题思路:
1.使用两个列表来存放需要替换的字符old = [‘0’, ‘1’, ‘l’, ‘O’],new = [’%’, ‘@’,‘L’, ‘o’]
2.对每个输入的字符串首先进行分割,注意到其实空格之前的字符串(也就是ID)是不会发生变化的,我们只需要处理后面的字符串(也就是密码)。
3.扫描后面的密码字符串,定义一个空字符串s,如果该字符在列表old中,将其在列表new中对应的字符添加到字符串s中,否则将原字符添加到s中。
4.定义一个空列表out,如果发生了替换行为(用一个flag来记录),则将替换之后的字符串s和原来的ID一起拼成一个新的字符串添加到out中。
5.如果out的长度不为0,则输出out的长度,并输出out里面的字符串。如果out的长度为0,则判断输入的n是否为1,为1输出(‘There is 1 account and no account is modified’),否则输出(‘There are %d accounts and no account is modified’%n)

old = ['0', '1', 'l', 'O']
new = ['%', '@','L', 'o']
n = int(input())
out = []
for i in range(n):
    l = input().split()
    s = ''
    flag = False
    for j in l[1]:
        if j in old:
            flag = True
            s += new[old.index(j)]
        else:
            s += j
    if flag:
        out.append(l[0]+ ' ' +s)
if len(out):
    print(len(out))
    print('\n'.join(out))
else:
    if n == 1:
        print('There is 1 account and no account is modified')
    else:
        print('There are %d accounts and no account is modified'%n)

你可能感兴趣的:(python,用Python刷PAT,(Advanced,Level),Practice)