SDUT-3328 JAVA判断合法标识符

Problem Description

输入若干行字符串,判断每行字符串是否可以作为JAVA语法的合法标识符。 判断合法标识符的规则:由字母、数字、下划线“_”、美元符号“$”组成,并且首字母不能是数字。

Input

 输入有多行,每行一个字符串,字符串长度不超过10个字符,以EOF作为结束。

Output

 若该行字符串可以作为JAVA标识符,则输出“true”;否则,输出“false”。

Sample Input

abc
_test
$test
a 1
a+b+c
a’b
123
变量

Sample Output

true
true
true
false
false
false
false
true
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		while(in.hasNext())
		{
			String s = in.nextLine();
			int flag = 0;
			for(int i = 0; i < s.length(); i++)
			{
				char c = s.charAt(i);
				if(i == 0)
				{
					if(Character.isJavaIdentifierStart(c)) 
					{
						flag = 1;
					}
					else
					{
						flag = 0;
						break;
					}
				}
				else
				{
					if(Character.isJavaIdentifierPart(c)) 
					{
						flag = 1;
					}
					else
					{
						flag = 0;
						break;
					}
				}
			}
			if(flag == 1)
			{
			System.out.println("true");
			}
			else 
			{
				System.out.println("false");
			}
		}
		in.close();
	}
}

 

你可能感兴趣的:(SDUT-3328 JAVA判断合法标识符)