hdu1501 Zipper DFS带剪枝

Zipper

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3613Accepted Submission(s): 1296


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.


Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3 cat tree tcraete cat tree catrtee cat tree cttaree

Sample Output


Data set 1: yes Data set 2: yes Data set 3: no
注意剪纸 不剪纸 超时
Source

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
char num1[224],num2[224],num3[424];
int len1,len2,len3,flag,hash[224][224];
void DFS( int a,int b,int c )
{
     if( len3==c )  
     {
         flag=1;
         return ;
     }
     if( hash[a][b]==1//若是该点已经标识表记标帜就代表该点以下的所有路线都接见过,就不须要持续深搜。    

       return ;
     hash[a][b]=1;
     if( num1[a]==num3[c] )
     {
           DFS( a+1,b,c+1 );
     }
     if( num2[b]==num3[c] )
     {
         DFS( a,b+1,c+1 );    
     }    
}
int main()
{
    int T;
    scanf( "%d"&T );
    forint i=1; i<=T; i++ )
    {
          flag=0;
          scanf( "%s%s%s",num1,num2,num3 );
          len1=strlen(  num1 ),len2=strlen( num2 ),len3=strlen( num3 );
          memset( hash,0sizeof( hash ) );
          DFS( 000 );
          printf(flag== 1 "Data set %d: yes\n": "Data set %d: no\n", i);     
    } 
    return 0;  
}

你可能感兴趣的:(hdu1501 Zipper DFS带剪枝)