#1082 : 然而沼跃鱼早就看穿了一切

1082 : 然而沼跃鱼早就看穿了一切

描述

fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx” 。

输入

输入包括多行。

每行是一个字符串,长度不超过200。

一行的末尾与下一行的开头没有关系。

输出

输出包含多行,为输入按照描述中变换的结果。

样例输入

The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB

样例输出

The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB

具体代码

import java.util.Scanner;
import java.util.Stack;
import java.util.regex.Matcher;
import java.util.regex.Pattern;


public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        String str = "";


        while(sc.hasNext()) {

            str = sc.nextLine();

            Pattern p = Pattern.compile("marshtomp", Pattern.CASE_INSENSITIVE);
            Matcher m = p.matcher(str);

            StringBuffer sb = new StringBuffer();



            while(m.find()) {
                m.appendReplacement(sb, "fjxmlhx");
            }
            m.appendTail(sb);

            System.out.println(sb);
        }











    }




}

你可能感兴趣的:(JAVA)