用JAVA做OJ时输入以EOF结束

Financial Management

时间限制:3000 ms  |  内存限制:65535 KB

描述

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

输入

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included. 

输出

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output. 

样例输入

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

样例输出

1581.42

题目的意思很简单,就是把输入的浮点数加起来,然后求个平均值,就OK啦。

但是对于初学java的,有一个难点,那就是题目要求以EOF结束,C、C++我们很熟悉,C语言的时候while(scanf(...)!=EOF),C++中while(cin>>?),java中怎么做呢?

java中有个hasNext()函数,作用就是判断是否还有下一个元素,以CTRL+Z结束。

好了明白这些,快点刷题吧~

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		// TODO Auto-generated method stub
	Scanner in = new Scanner(System.in);
	   double sum = 0.0;
	   int num = 0;
	   while(in.hasNext())
	   {
		   double a=in.nextDouble();
		   num++;
		   sum+=a;
	   }
	   System.out.println(sum/num);
	}
}

 

你可能感兴趣的:(java学习,赛码网刷题)