问题 L: Crested Ibis vs Monster--------------------------------------------思维(完全背包)

题目描述
Ibis is fighting with a monster.
The health of the monster is H.
Ibis can cast N kinds of spells. Casting the i-th spell decreases the monster’s health by Ai, at the cost of Bi Magic Points.
The same spell can be cast multiple times. There is no way other than spells to decrease the monster’s health.
Ibis wins when the health of the monster becomes 0 or below.
Find the minimum total Magic Points that have to be consumed before winning.

Constraints
·1≤H≤104
·1≤N≤103
·1≤Ai≤104
·1≤Bi≤104
·All values in input are integers.
输入
Input is given from Standard Input in the following format:

H N
A1 B1
:
AN BN

输出
Print the minimum total Magic Points that have to be consumed before winning.
样例输入 Copy
【样例1】

9 3
8 3
4 2
2 1
【样例2】
100 6
1 1
2 3
3 9
4 27
5 81
6 243
【样例3】
9999 10
540 7550
691 9680
700 9790
510 7150
415 5818
551 7712
587 8227
619 8671
588 8228
176 2461
样例输出 Copy
【样例1】

4
【样例2】
100
【样例3】
139815
提示
样例1解释

First, let us cast the first spell to decrease the monster’s health by 8, at the cost of 3 Magic Points. The monster’s health is now 1.
Then, cast the third spell to decrease the monster’s health by 2, at the cost of 1 Magic Point. The monster’s health is now −1.
In this way, we can win at the total cost of 4 Magic Points.
样例2解释
It is optimal to cast the first spell 100 times.

解析:
套路题,完全背包但是会超过指定的体积(假设x),所以我们的体积遍历到x2。最后我们在[x,x2]区间内找最小值


#include <bits/stdc++.h>
using namespace std;

const int maxn = 2e4 + 10;

int n, m;
int v[maxn], w[maxn];
int f[maxn];

int main()
{
    scanf("%d%d",&n,&m);
    memset(f,0x3f,sizeof f);
    f[0]=0;
    for(int i = 1; i <= m; i ++)    scanf("%d%d",&v[i],&w[i]);
    for(int i = 1; i <= m; i ++){
        for(int j = v[i]; j <= 2e4; j ++)
            f[j] = min(f[j], f[j - v[i]] + w[i]);
    }
    int minn=0x3f3f3f3f;
    for(int i=n;i<=2e4;i++) minn=min(minn,f[i]);
    cout<<minn<<endl;
    return 0;
}

你可能感兴趣的:(DP,套路题)