【杭电1004】java-字符串

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 112819    Accepted Submission(s): 44087


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.

 
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 
Sample Input
 
   
5 green red blue red red 3 pink orange pink 0
 
Sample Output
 
   
red pink
code:
import java.util.*;
public class Main{
	public static void main(String[] args){
	Scanner in=new Scanner(System.in);
	int n=in.nextInt();
	while(n!=0){
		String[] tempArray=new String[n];//定义字符串 
		in.nextLine();
		for(int i=0;imax){//记录出现最多的次数 
			max=cout;id=i;		}
	}
	System.out.println(tempArray[id]);
	n=in.nextInt();	
		}
		
	}
	}



你可能感兴趣的:(编程语言,java学习入门笔记,杭电acm~bestcoder)