Wireless Network --并查集

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL

SUCCESS

分析:这道题就是一个并查集的简单应用,只要满足题目所给的距离值即可纳入能连通的集合,同时也要满足被修好的条件,如果两个电脑都在这个集合里面那么就可以通信了。

上代码:

import java.util.*;

public class Main {
    static Scanner in = new Scanner(System.in);
    static int n,d;
    static boolean[] vis = new boolean[1005];
    static int[] f = new int[1005];
    static List st = new ArrayList();
    //计算两点距离
    static double dis(Node s1,Node s2){
    	 double d=Math.sqrt((s1.x-s2.x)*(s1.x-s2.x)+(s1.y-s2.y)*(s1.y-s2.y));
    	  return d;
    }
    //判断是否可以纳入集合
    static void judge(int x){
    	for (int i = 1; i <= n; i++) {
    		//纳入的条件就是已经被修好并且两者之间的距离小于最大值
		   if(vis[i]&&dis(st.get(i-1),st.get(x-1))<=d+(1e-6))
				   merge(i, i+1);
		}
    }
    static int find(int x){
    	int r = x;
    	while(r!=f[r]){
    		r=f[r];
    	}
    	return r;
    }
    static void merge(int x,int y){
    	int t1 = find(x);
    	int t2 = find(y);
    	if(t1!=t2)
    		f[t1]=t2;
    }
	public static void main(String[] args) {
		Arrays.fill(vis, false);
	       n = in.nextInt();
	       d = in.nextInt();
	    for (int i = 1; i <=n; i++) {
			   f[i]=i;
		}
	     for (int i = 1; i <= n; i++) {
			Node s = new Node();
			s.x=in.nextInt();
			s.y=in.nextInt();
			st.add(s);
		 }
	     String s;
	     int t1,t2;
        while(in.hasNext()){
        	 s = in.next();
        	if(s.charAt(0)=='0'){
        		t1 = in.nextInt();
        		vis[t1]=true;//一定要标记,不然相当于没有修过即使距离满足也没用啊。。
        		judge(t1);
        	}else{
        		t1 = in.nextInt();
        		t2 = in.nextInt();
        	    if(find(t1)==find(t2))//如果在集合里面,说明联通了
        			System.out.println("SUCCESS");
        		else
        			System.out.println("FAIL");
        	}
        }
	}

}
class Node{
	int x,y;
}

就是判断条件不断进行合并,实质就是一个 在合并的时候带有约束条件的并查集。。。。


你可能感兴趣的:(数据结构)