字符串替换

将文本文件中指定的字符串替换成新字符串。 由于目前的OJ系统暂时不能支持用户读入文件,我们编写程序从键盘输入文件中的内容,当输入的一行为end时,表示结束。end后面有两个字符串,要求用第二个字符串替换文本中所有的第一个字符串。


输入样例:

Xi’an Institute of Posts and Telecommunications is co-designed and implemented by
by the People’s Government of Shaanxi Province and the Ministry of Industry and
Information Technology. The Institute is located in Xi’an,a historic city in
Northwest China, famous for its magnificent ancient culture.
end
Institute
University

输出样例:

Xi’an University of Posts and Telecommunications is co-designed and implemented by
by the People’s Government of Shaanxi Province and the Ministry of Industry and
Information Technology. The University is located in Xi’an,a historic city in
Northwest China, famous for its magnificent ancient culture.

import java.util.Scanner;
public class StringReplace{
	public static void main(String[] args){
		Scanner in=new Scanner(System.in);
		String string="";
		while(in.hasNextLine()){
			String s=in.nextLine();
			if(s.equals("end")){
				break;
			}
			else{
				string=string+s+"\n";
			}
		}
		String a=in.next();
		String b=in.next();
		System.out.println(string.replaceAll(a, b));
	}
}


你可能感兴趣的:(java基础练习题)