Guess the number

文章目录

        • 题目
        • 代码

这是一道简单题啦,不做过多分析,代码附上

题目

Happy new year to everybody!

Now, I want you to guess a minimum number x betwwn 1000 and 9999 to let

(1) x % a = 0;

(2) (x+1) % b = 0;

(3) (x+2) % c = 0;

and a, b, c are integers between 1 and 100.

Given a,b,c, tell me what is the number of x ?
Input
The number of test cases c is in the first line of input, then c test cases followed.every test contains three integers a, b, c.

Output
For each test case your program should output one line with the minimal number x, you should remember that x is between 1000 and 9999. If there is no answer for x, output “Impossible”.

Sample Input
2
44 38 49
25 56 3

Sample Output
Impossible
2575

代码

#include<stdio.h>
int main(){
	int a,b,c,n,i;
	scanf("%d",&n);
	while(n--){
		scanf("%d %d %d",&a,&b,&c);
		for(i=1000;i<=9999;i++)
			if(i%a==0&&(i+1)%b==0&&(i+2)%c==0)		break;
		if(i>=10000) 
			printf("Impossible\n");
		else
			printf("%d\n",i);
	}
	return 0;
}

你可能感兴趣的:(acm,c语言)