计算球体积 JAVA

Problem Description

根据输入的半径值,计算球的体积。
Input

输入数据有多组,每组占一行,每行包括一个实数,表示球的半径。
Output

输出对应的球的体积,对于每组输入数据,输出一行,计算结果保留三位小数。
Sample Input

1
1.5
Sample Output

4.189
14.137
Hint

define PI 3.1415927

Source

HDOJ

import java.text.DecimalFormat;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner str = new Scanner(System.in);
        DecimalFormat df = new DecimalFormat("0.000");
        double x, y;
        while(str.hasNext())
        {
            x = str.nextDouble();
            y = (4.0 * (3.1415927) * x * x * x) / 3;
            System.out.println(df.format(y));
        }
        str.close();
    }

}

你可能感兴趣的:(JAVA,java)