POJ 3250 Bad Hair Day(单调栈)

Bad Hair Day

Time Limit: 2000MS Memory Limit: 65536K

Description

Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:
POJ 3250 Bad Hair Day(单调栈)_第1张图片

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow’s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow’s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i.
Output

Line 1: A single integer that is the sum of c1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

思路

反向遍历数组,用一个单调递增栈存储元素值以及计数器(计数器中保存的是元素右边<该元素值的元素个数+1),当前元素值小于等于栈顶元素时,直接入栈;否则从栈顶开始将元素值小于当前元素的元素出栈,并将这些元素的计数器的值累加作为当前元素的计数器值,最后将当前元素入栈。

代码

// POJ 3250. Bad Hair Day
// Time Limit: 2000MS		Memory Limit: 65536K
// Total Submissions: 29087		Accepted: 10008
// Description

// Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

// Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

// Consider this example:

//         =
// =       =
// =   -   =         Cows facing right -->
// =   =   =
// = - = = =
// = = = = = =
// 1 2 3 4 5 6 
// Cow#1 can see the hairstyle of cows #2, 3, 4
// Cow#2 can see no cow's hairstyle
// Cow#3 can see the hairstyle of cow #4
// Cow#4 can see no cow's hairstyle
// Cow#5 can see the hairstyle of cow 6
// Cow#6 can see no cows at all!

// Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

// Input

// Line 1: The number of cows, N.
// Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
// Output

// Line 1: A single integer that is the sum of c1 through cN.
// Sample Input

// 6
// 10
// 3
// 7
// 4
// 12
// 2
// Sample Output

// 5


import java.io.FileInputStream;
import java.io.FileNotFoundException;
import java.util.LinkedList;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) throws FileNotFoundException {
        Scanner sc = new Scanner(System.in);
        // Scanner sc = new Scanner(new FileInputStream("input.txt"));
        int n = sc.nextInt(), i = 0, cur = 0;
        long sum = 0;
        int[] arr = new int[n];
        LinkedList<Node> stack = new LinkedList<Node>();
        for (i=0; i<n; ++i) {
            arr[i] = sc.nextInt();
        }
        for (i=n-1; i>=0; --i) {
            int val = arr[i];
            cur = 1;
            while (!stack.isEmpty() && val > stack.getLast().val) {
                int tmp = stack.removeLast().right;
                cur += tmp;
                sum += (long)tmp;
            }
            stack.add(new Node(val, cur));
        }
        sc.close();
        System.out.println(sum);
    }
}

class Node {
    public int val, right;

    public Node(int _val, int _right) {
        val = _val;
        right = _right;
    }
}

你可能感兴趣的:(百练OJ/poj,poj,单调栈)