hdu_2084数塔(动态规划--初步)





                           数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16588    Accepted Submission(s): 9969


Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?

已经告诉你了,这是个DP的题目,你能AC吗?
 

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input
 
   
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
 

Sample Output
 
   
30
 

Source
2006/1/15 ACM程序设计期末考试
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1176  1087  1159  2602  1058 





package 动态规划;

import java.util.Scanner;

public class hdu_2084数塔 {

	public static void main(String[] args) {
		
		Scanner sc = new Scanner(System.in); 
           int n=sc.nextInt();
           while(n-->0){
        	   int m=sc.nextInt();
        	   int[][]f=new int[m+1][m+1];
        	   int c=0,i,j = 1;
        	   for( i=1;i<=m;i++)
        		   for( j=1;j<=i;j++)
        			   f[i][j]=sc.nextInt();       			 

        	   for( i=m-1;i>=1;i--)//从倒数第二层开始
                    for( j=1;j<=i;j++)//自下而上、塔的下方向上
                      f[i][j]=f[i][j]+Math.max(f[i+1][j], f[i+1][j+1]);
        		          	   
       		   System.out.println(f[1][1]);
           }
	}

}



你可能感兴趣的:(hdu_2084数塔(动态规划--初步))