Piggy-Bank ----完全背包

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 


But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
Sample Input
3                            组数
10 110                    背包装东西前的重量和装东西后的重量

2                            物品数

1 1                          第一个物品的价值和重量

30 50                       第二个物品
10 110                     第二组......
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.

This is impossible.

题意:求恰好装满背包,求最小总价值,背包无法恰好装满输出“...imposs...”(完全背包问题),物品无限数量

注意:1.数组范围较大,定义在外边。memset无法将初始值定为0以外的数。

2.要求的是最小值,所以就要赋值为最大 。要比最大结果大,否则会wa。0x3f不行,原因未知。

3.i=0时,dp【0】=0;初始值很重要。

4.k从w【i-1】开始,否则数组下标会爆,且w【i-1】之前无法放入,无意义。

5..int p[10005];//硬币的价值  
   int w[10005];//硬币的重量  
   int dp[10005];//体积为i时可以存放多少钱

思路:

完全背包,动态规划。

1.要求的是最小值,所以就要赋值为最大 。

2.恰好装满,赋初值为最大/小值

    不用恰好装满,只求价值最大/小,赋初值为0;

3.阅读并理解背包九讲(qq),并记模板。

4.dp[k]体积为k时可以存放多少钱,状态方程dp[k]=min(dp[k-w[i-1]]+p[i-1 ],dp[k]);

    如果dp[k]小,即不再添加本物品,如果dp[k-w[i-1]]+p[i-1 ]小即添加一个本物品,在此之前dp[k-w[i-1]]可能已经添加了

    j个本物品(j属于0,1,2.....),即可实现一个物品多次使用。


AC代码

# include
# include
# include
# include
using namespace std;
# define INF 9999999
int p[10005];//硬币的价值  
int w[10005];//硬币的重量  
int dp[10005];//体积为i时可以存放多少钱
 int main ()
 {
  freopen("in.txt","r",stdin); 
  int t;
  while (~scanf("%d",&t))
  {
  for (int ii=0;ii  {
  int f1,f2;
  scanf("%d%d",&f1,&f2); 
  int f=f2-f1;
  int n;
    scanf("%d",&n);
  for (int i=0;i  scanf("%d %d",&p[i],&w[i]);
// memset(dp,INF,sizeof(dp));   错
    for(int i=0;i<=f ;i++)  
        {  
            dp[i] = INF;//要求的是最小值,所以就要赋值为最大  
        }  
dp[0]=0;                         //
for (int i=1;i<=n;i++)
{
for (int k=w[i-1];k<=f;k++)     //
{
dp[k]=min(dp[k-w[i-1]]+p[i-1 ],dp[k]);

}
}
            if(dp[f] == INF)  
            {  
                printf("This is impossible.\n");  
            }  
            else  
            {  
                printf("The minimum amount of money in the piggy-bank is %d.\n",dp[f]);  
            }  

}
return 0;
 }

你可能感兴趣的:(动态规划,基础dp)