HDU1002

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 488097 Accepted Submission(s): 94190

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

刚开始还以为像c一样弄个字符串数组,再按进位一步一步加,结果论坛一看发现了一个BigInteger,就是用来做大数计算的
然后还要注意一下格式,最后一组数据完了以后没有多余的那个空行

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner a = new Scanner(System.in);
		int n = a.nextInt();
		for(int i=1;i<=n;i++)
		{
			BigInteger zhi1 = a.nextBigInteger();
			BigInteger zhi2 = a.nextBigInteger();
			System.out.println("Case "+i+":");
			System.out.println(zhi1+" + "+zhi2+" = "+zhi1.add(zhi2));
			if(i!=n)
				System.out.println();
		}

	}

}

你可能感兴趣的:(题)