两个十六进制数相加

 

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

 

Sample Input
+A -A +1A 12 1A -9 -1A -12 1A -AA
 

 

Sample Output
0 2C 11 -2C -90
 

 AC代码:

import java.util.Scanner;

public class Main {
    public static void main(String _[]) {
        Scanner s = new Scanner(System.in);
        while (s.hasNext()) {
            long i = Long.parseLong(s.next().replaceAll("\\+", ""), 16) +
                    Long.parseLong(s.next().replaceAll("\\+", ""), 16);
            if (i < 0)
                System.out.println("-" + Long.toHexString(-i).toUpperCase());
            else
                System.out.println(Long.toHexString(i).toUpperCase());
        }
    }
}

  

转载于:https://www.cnblogs.com/ixummer/p/8509887.html

你可能感兴趣的:(两个十六进制数相加)