1057: 【求[X,Y]内被除3余1并且被除5余3的整数的和】

题目

Description
输入两个正整数X,Y,求出[X,Y]内被除3余1并且被除5余3的整数的和
Input
输入两个正整数X,Y
Output
求所有满足条件的数的和
Sample Input
200 800
Sample Output
20020


代码块

import java.util.Scanner;//输入包

public class Main {
    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);//输入流
        int x = cin.nextInt();
        int y = cin.nextInt();
        int s = 0;
        for (int i = x; i <= y; i++)//进行循环判断
            if (i % 3 == 1 && i % 5 == 3)
                s += i;
        System.out.println(s);
        cin.close();//关闭输入流
    }
}

你可能感兴趣的:(acm编程,安徽科技学院,java,acm)