Bone Collector--hdu2602(01背包)

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Bone Collector--hdu2602(01背包)
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

 

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 

 

Sample Output
14
 

 

Author
Teddy
 

 

Source
 
 
题意:给你n个骨头的价值和体积,求体积为V时最多有多少价值;
01背包问题:
递推公式:dp[i][j]=dp[i+1][j];(j<w[i]);
     dp[i][j]=max(dp[i+1][j],dp[i+1][j-w[i]]+v[i]);
代码如下:
 
关于i的逆向循环;
Bone Collector--hdu2602(01背包)
#include<iostream>

#include<cstdio>

#include<cstring>

#include<cstdlib>

#include<algorithm>

using namespace std;

#define N 1100

   int dp[N][N];

int main()

{

    int T,i,j,V,n,v[N],w[N];



    scanf("%d",&T);

    while(T--)

    {

        memset(dp,0,sizeof(dp));

        scanf("%d%d",&n,&V);

        for(i=0;i<n;i++)

                scanf("%d",&v[i]);

        for(i=0;i<n;i++)

                scanf("%d",&w[i]);

        for(i=n-1;i>=0;i--)

        {

            for(j=0;j<=V;j++)

            {

                if(j<w[i])

                    dp[i][j]=dp[i+1][j];

                else

                    dp[i][j]=max(dp[i+1][j],dp[i+1][j-w[i]]+v[i]);

            }

        }

        printf("%d\n",dp[0][V]);

    }

    return 0;

}
View Code
下面是关于i的正向循环;
Bone Collector--hdu2602(01背包)
#include<iostream>

#include<cstdio>

#include<cstring>

#include<cstdlib>

#include<algorithm>

using namespace std;

#define N 1100

   int dp[N][N];

int main()

{

    int T,i,j,V,n,v[N],w[N];



    scanf("%d",&T);

    while(T--)

    {

        memset(dp,0,sizeof(dp));

        scanf("%d%d",&n,&V);

        for(i=0;i<n;i++)

                scanf("%d",&v[i]);

        for(i=0;i<n;i++)

                scanf("%d",&w[i]);

        for(i=0;i<n;i++)

        {

            for(j=0;j<=V;j++)

            {

                if(j<w[i])

                    dp[i+1][j]=dp[i][j];

                else

                    dp[i+1][j]=max(dp[i][j],dp[i][j-w[i]]+v[i]);

            }

        }

        printf("%d\n",dp[n][V]);

    }

    return 0;

}
View Code

用一维数组;

Bone Collector--hdu2602(01背包)
#include<iostream>

#include<cstdio>

#include<cstring>

#include<cstdlib>

#include<algorithm>

using namespace std;

#define N 1100

int dp[N];

int main()

{

    int T,i,j,V,n,v[N],w[N];



    scanf("%d",&T);

    while(T--)

    {

        memset(dp,0,sizeof(dp));

        scanf("%d%d",&n,&V);

        for(i=0;i<n;i++)

                scanf("%d",&v[i]);

        for(i=0;i<n;i++)

                scanf("%d",&w[i]);

        for(i=0;i<n;i++)

        {

            for(j=V;j>=w[i];j--)

            {

                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);

            }

        }

        printf("%d\n",dp[V]);

    }

    return 0;

}
View Code

 

你可能感兴趣的:(Collector)