HDU 5546 Ancient Go (dfs)

Ancient Go

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1804 Accepted Submission(s): 577

Problem Description
Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

⋅The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
⋅Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅The chess of the same color makes connected components(connected by the board lines), for each of the components, if it’s not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅When one of the player makes his move, check the opponent’s components first. After removing the dead opponent’s components, check with the player’s components and remove the dead components.
One day, Yu Zhou was playing ancient go with Su Lu at home. It’s Yu Zhou’s move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu’s chess.

Input
The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. ′.′ represents an empty cell. ′x′ represents a cell with black chess which owned by Yu Zhou. ′o′ represents a cell with white chess which owned by Su Lu.

Output
For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu’s components. Can not kill in one move!!! otherwise.

Sample Input
2

…….xo
………
………
..x……
.xox….x
.o.o…xo
..o……
…..xxxo
….xooo.

……ox.
…….o.
…o…..
..o.o….
…o…..
………
…….o.
…x…..
……..o

Sample Output
Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!
Hint

In the first test case, Yu Zhou has 4 different ways to kill Su Lu’s component.

In the second test case, there is no way to kill Su Lu’s component.

Source
The 2015 China Collegiate Programming Contest

五子棋规则,问X能否一步杀死O(0步的时候已经围好了也算)。水题蜜汁wa了很久后来稍微修改了一下写法莫名其妙又过了,真的好奇怪啊。。

#include "cstring"
#include "cstdio"
#include "string.h"
#include "iostream"
#include "set"
using namespace std;
char mmap[11][11];
int mark[11][11];
int mymark[11][11];
int flag=0;
int dir[4][2]={0,1,0,-1,1,0,-1,0};
void dfs(int m,int n)
{
    if(flag>1)
        return;
    for(int i=0;i<=3;i++)
    {
        if(mmap[m+dir[i][0]][n+dir[i][1]]!='x'&&mark[m+dir[i][0]][n+dir[i][1]]==0)
        {
            mark[m+dir[i][0]][n+dir[i][1]]=1;
            if(mmap[m+dir[i][0]][n+dir[i][1]]=='.'&&mymark[m+dir[i][0]][n+dir[i][1]]==0)
            {
                flag++;
                mymark[m+dir[i][0]][n+dir[i][1]]=1;
            }
            if(mmap[m+dir[i][0]][n+dir[i][1]]=='o')
                dfs(m+dir[i][0],n+dir[i][1]);
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    flag=0;
    int finalans=0;
    for(int i=1;i<=t;i++)
    {
        finalans=0;
        flag=0;
        for(int j=1;j<=9;j++)
        {
            scanf("%s",mmap[j]+1);
        }
         for(int i=0;i<=10;i++)
        {
            mmap[0][i]='x';
            mmap[10][i]='x';
            mmap[i][0]='x';
            mmap[i][10]='x';
        }
        for(int j=1;j<=9;j++)
        {
            for(int k=1;k<=9;k++)
            {
                flag=0;
                if(finalans==1)
                    break;
                if(mmap[j][k]=='o')
                {
                    int cnt=0;
                    if(mmap[j+1][k]!='o'&&mmap[j-1][k]!='o'&&mmap[j][k+1]!='o'&&mmap[j][k-1]!='o')
                    {
                        if(mmap[j+1][k]=='x')
                            cnt++;
                        if(mmap[j-1][k]=='x')
                            cnt++;
                        if(mmap[j][k+1]=='x')
                            cnt++;
                        if(mmap[j][k-1]=='x')
                            cnt++;
                        if(cnt>=3)
                        {
                            finalans=1;
                            continue;
                        }
                        continue;
                    }
                    memset(mark,0,sizeof(mark));
                    memset(mymark,0,sizeof(mymark));
                    mark[j][k]=1;
                    dfs(j,k);
                    if(flag<=1)
                        finalans=1;
                }
            }
        }
        printf("Case #%d: ",i);
        if(finalans==1)
        {
            printf("Can kill in one move!!!\n");
        }
        else
            printf("Can not kill in one move!!!\n");
    }

}

你可能感兴趣的:(搜索)