试题 算法训练 单词翻转 文章翻转 JAVA

输入格式
  输入包括一个英语句子。
输出格式
  按单词的顺序把单词倒序输出
样例输入
I love you
样例输出
you love I
数据规模和约定
  简单的字符串操作
  
思路:看见字符串并且还有空格,那就王split 上面靠就可以了~~

import java.util.Scanner;

public class Main {
     
	public static void main(String[] args) {
     
		Scanner scanner = new Scanner(System.in);
		String s1 = scanner.nextLine();
		String[] split = s1.split(" ");       // 分割字符串
		for (int i = split.length - 1; i >= 0; i--) {
          // 倒序输出
			System.out.print(split[i] + " ");             // 分割后的字符串
		}
	}
}

小剧场:追逐梦想的那些年。Years of chasing dreams.

你可能感兴趣的:(蓝桥杯,字符串,java,split,倒序输出,文章翻转)