(Python实现)PAT 1001 A+B Format

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10的6次方≤a,b≤10的6次方
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

解题思路:
数字的格式化输出
format(x, ‘,’) 表示指定逗号位数字的千分位分隔符

代码:

a, b = map(int, input().split())
print(format(a+b, ','))

提交结果
(Python实现)PAT 1001 A+B Format_第1张图片

你可能感兴趣的:(每日一题,python)