[JAVA](PAT)1008 ELEVATOR (20)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题目大意

给定一串整型串,第一个整型N是总共有多少个请求,后面的整型串是请求的楼层。

每上升一层花费6秒,下降一层花费4秒,停在一层花费5秒。

分析:

使用now变量记录当前楼层,和下一个请求楼层进行对比,累加花费时间,最后输出答案

Java实现

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Main {
    public static void main(String[] args) throws Exception{
    	BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        String[] line = br.readLine().split(" ");
        int num = Integer.valueOf(line[0]);
        int floor[] = new int[num];
        for(int i = 1; i <= num; i++){
            floor[i - 1] = Integer.valueOf(line[i]);
        }
        br.close();
        int total = 0;
        int now = 0;
        for(int i : floor){
            if(i > now){
                total = total + 5 +6 * (i - now);
                now = i;
            }else
                if(i < now){
                total = total + 5 + 4 * (now - i);
                now = i;
                }else
                    if(i == now){
                        total = total + 5;
                    }
        }
        System.out.print(total);
    }
}

你可能感兴趣的:(PAT,PAT,Java)