POJ1007-DNA Sorting-ACM

DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 83442   Accepted: 33584

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6

AACATGAAGG

TTTTGGCCAA

TTTGGCCAAA

GATCAGATTT

CCCGGGGGGA

ATCGATGCAT

Sample Output

CCCGGGGGGA

AACATGAAGG

GATCAGATTT

ATCGATGCAT

TTTTGGCCAA

TTTGGCCAAA

重点,归并排序求逆序数

#include <stdio.h>

#include <malloc.h>

#include <string.h>

#define MAXN 256

char a[MAXN];

char c[MAXN];

int cnt=0;

void MergeSort(int l, int r){

	int mid, i, j, tmp;

	if( r > l+1 ){

		mid = (l+r)/2;

		MergeSort(l, mid);

		MergeSort(mid, r);

		tmp = l;

		for( i=l, j=mid; i < mid && j < r; ){

			if( a[i] > a[j] ){

				c[tmp++] = a[j++];

				cnt += mid-i; //

			}

			else c[tmp++] = a[i++];

		}

		if( j < r ) for( ; j < r; ++j ) c[tmp++] = a[j];

		else for( ; i < mid; ++i ) c[tmp++] = a[i];

		for ( i=l; i < r; ++i ) a[i] = c[i];

	}

}

int main(void){

	int n,m;

	scanf("%d%d",&n,&m);

	char ** strs = (char **)malloc(m*sizeof(char*));

	int * cnts = (int *)malloc(m*sizeof(int));

	int i;

	for(i = 0;i<m;i++){

		strs[i] = (char *)malloc((n+1)*sizeof(char));

		scanf("%s",strs[i]);

		//printf("%s\n",strs[i]);

		cnt = 0;

		strcpy(a,strs[i]);

		//printf("%s\n",a);

		MergeSort(0,n);

		//printf("%d\n",cnt);

		cnts[i] = cnt;

	}

	

	for(i = 0;i<m-1;i++){

		int j,p=i;

		for(j = i+1;j<m;j++){

			if(cnts[p]>cnts[j]){

				p = j;

			}

		}

		if(p!=i){

			int tmp = cnts[p];

			cnts[p] = cnts[i];

			cnts[i] = tmp;

			char * str = strs[p];

			strs[p] = strs[i];

			strs[i] = str;

		}

	}

	for(i = 0;i<m;i++){

		printf("%s\n",strs[i]);

		free(strs[i]);

	}

	free(strs);

	free(cnts);

	return 0;

}


 

 

你可能感兴趣的:(sort)