POJ 1077 Eight(单向搜索)

Eight
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18387   Accepted: 8182   Special Judge

Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  4 
5 6 7 8
9 10 11 12
13 14 15 x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
 1  2  3  4    1  2  3  4    1  2  3  4    1  2  3  4 
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input

You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle
 1  2  3 
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.

Sample Input

 2  3  4  1  5  x  7  6  8 

Sample Output

ullddrurdllurdruldr

Source

 
 
 
用各种方法都写一下。
又写了一个新的代码:
/*

POJ 1077 Eight

单向搜索,

从正向开始找目标点

康托展开作为hash值



AC  G++  8876K  96MS

*/

#include<stdio.h>

#include<string.h>

#include<iostream>

#include<string>

using namespace std;

const int MAXN=362881;//9!=362880

struct Node

{

    int s[9];

    int pre;//记录前一个结点

    int dir;//记录前一个结点到该结点的方向

}que[MAXN];

bool hash[MAXN];

int path[MAXN];



int fac[]={1,1,2,6,24,120,720,5040,40320,362880};//康拖展开判重

//         0!1!2!3! 4! 5!  6!  7!   8!    9!

int cantor(int *s)

{

    int sum=0;

    for(int i=0;i<9;i++)

    {

        int num=0;

        for(int j=i+1;j<9;j++)

          if(s[j]<s[i])

            num++;

        sum+=(num*fac[9-i-1]);

    }

    return sum;

}

int move[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//u,d,l,r

void output(int len)

{

    for(int i=len-1;i>=0;i--)

    {

        if(path[i]==0) printf("u");

        else if(path[i]==1) printf("d");

        else if(path[i]==2) printf("l");

        else if(path[i]==3) printf("r");

    }

    printf("\n");

}

void bfs()

{

    int front=-1,rear=0;

    que[0].pre=-1;

    que[0].dir=-1;

    memset(hash,false,sizeof(hash));

    hash[cantor(que[0].s)]=true;

    if(cantor(que[0].s)==0){output(0);return;}

    while(front<rear)

    {

        front++;

        int tmp;

        for(tmp=0;tmp<9;tmp++)

          if(que[front].s[tmp]==9)

            break;

        int x=tmp/3;

        int y=tmp%3;

        for(int i=0;i<4;i++)

        {

            int tx=x+move[i][0];

            int ty=y+move[i][1];

            if(tx<0||tx>2||ty<0||ty>2)continue;

            que[rear+1]=que[front];

            que[rear+1].pre=front;

            que[rear+1].dir=i;

            que[rear+1].s[tmp]=que[rear+1].s[tx*3+ty];

            que[rear+1].s[tx*3+ty]=9;

            int now=cantor(que[rear+1].s);

            if(now==0)//到达目标

            {

                int len=0;

                int t=rear+1;

                while(que[t].pre!=-1)

                {

                    path[len++]=que[t].dir;

                    t=que[t].pre;

                }

                output(len);

                return;

            }

            if(!hash[now])

            {

                rear++;

                hash[now]=true;

            }



        }

    }

}

int main()

{

   // freopen("in.txt","r",stdin);

   // freopen("out.txt","w",stdout);

    char str[10];

    while(scanf("%s",&str)!=EOF)

    {

        if(str[0]=='x') que[0].s[0]=9;

        else que[0].s[0]=str[0]-'0';

        for(int i=1;i<9;i++)

        {

            scanf("%s",&str);

            if(str[0]=='x') que[0].s[i]=9;

            else que[0].s[i]=str[0]-'0';

        }

        bfs();

    }

    return 0;

}

 

你可能感兴趣的:(poj)