1031. Hello World for U (20) PAT


题目:
http://pat.zju.edu.cn/contests/pat-a-practise/1031

分析:

简单题,调整数组的输出次序就可以了。

输入数组长度为len。n1 = n3 = (len+2)/3;   n2 = len - n1 - n3;

第一行最左边对应的是原数组的第一个字符,最后边对应的是原数组的最后一个字符。总共输出n1行。


题目描述:

 

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d

e  l

l  r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!

Sample Output:
h   !

e   d

l   l

lowor

 


参考代码:

 

#include<iostream>

#include<string.h>

using namespace std;

#define max 85

char input[max];



int main()

{

	int len;

    int n1,n2,n3;

	int i,j;

	cin>>input;

	len = strlen(input);

	n1 = n3 = (len + 2) / 3 ;

	n2 = len - 2*n1;

    for(i=0; i<n1-1; i++)

	{

		cout<<input[i];

		for(j=0; j<n2; j++) cout<<" ";

		cout<<input[len-1-i]<<endl;

	}

	for(j=i; j<len-i; j++)

		cout<<input[j];

	cout<<endl;





	return 0;

}


 

 

你可能感兴趣的:(Hello world)