实验要求:
IP地址规划:
area1:
172.16.32.0/21
172.16.40.0/21
172.16.48.0/21
172.16.56.0/21
area 0:
172.16.64.0/21
172.16.72.0/21
172.16.80.0/21
172.16.88.0/21
area 2
172.16.96.0/21
172.16.104.0/21
172.16.112.0/21
area 3:
172.16.128.0/21
172.16.136.0/21
172.16.144.0/21
area 4:
172.16.160.0/21
172.16.168.0/21
172.16.176.0/21
eigrp :
172.16.192.0/20
172.16.208.0/20
配置MGRE环境(R3为中心站点):
R3:
R5:
R6:
R7:
在R3、R5、R6、R7上写一条缺省路由指向外网ISP
基本配置:
R1:
interface GigabitEthernet0/0/0
ip address 172.16.64.1 255.255.248.0
interface LoopBack0
ip address 17.16.72.1 255.255.248.0
R2:
interface GigabitEthernet0/0/0
ip address 172.16.64.2 255.255.248.0
interface LoopBack0
ip address 172.16.80.1 255.255.248.0
R3:
interface Serial3/0/0
ip address 34.1.1.1 255.255.255.0
interface GigabitEthernet0/0/1
ip address 172.16.64.3 255.255.248.0
interface LoopBack0
ip address 172.16.88.1 255.255.248.0
ip route-static 0.0.0.0 0.0.0.0 34.1.1.2
R4:
interface Serial3/0/0
ip address 34.1.1.2 255.255.255.0
interface Serial3/0/1
ip address 45.1.1.2 255.255.255.0
interface Serial4/0/0
ip address 46.1.1.2 255.255.255.0
interface Serial4/0/1
ip address 47.1.1.2 255.255.255.0
interface LoopBack0
ip address 4.4.4.4 255.255.255.0
R5:
interface Serial3/0/1
ip address 45.1.1.1 255.255.255.0
interface LoopBack0
ip address 172.16.40.1 255.255.248.0
ip route-static 0.0.0.0 0.0.0.0 45.1.1.2
R6:
interface Serial4/0/0
ip address 46.1.1.1 255.255.255.0
interface Serial4/0/1
ip address 172.16.96.1 255.255.248.0
interface LoopBack0
ip address 172.16.48.1 255.255.248.0
ip route-static 0.0.0.0 0.0.0.0 46.1.1.2
R7:
interface Serial4/0/0
ip address 172.16.128.1 255.255.248.0
interface Serial4/0/1
ip address 47.1.1.1 255.255.255.0
interface LoopBack0
ip address 172.16.56.1 255.255.248.0
ip route-static 0.0.0.0 0.0.0.0 47.1.1.2
R8:
interface Serial4/0/0
ip address 172.16.128.2 255.255.248.0
interface Serial4/0/1
ip address 172.16.136.1 255.255.248.0
interface LoopBack0
ip address 172.16.144.1 255.255.248.0
R9:
interface Serial4/0/0
ip address 172.16.160.1 255.255.248.0
interface Serial4/0/1
ip address 172.16.136.2 255.255.248.0
interface LoopBack0
ip address 172.16.168.1 255.255.248.0
R10:
interface Serial4/0/0
ip address 172.16.160.2 255.255.248.0
interface LoopBack0
ip address 172.16.176.1 255.255.248.0
R11:
interface Serial4/0/0
ip address 172.16.104.1 255.255.248.0
interface Serial4/0/1
ip address 172.16.96.2 255.255.248.0
interface LoopBack0
ip address 172.16.112.1 255.255.248.0
R12:
interface Serial4/0/0
ip address 172.16.104.2 255.255.248.0
OSPF的配置:
R1:
ospf 1 router-id 1.1.1.1
area 0.0.0.1
network 172.16.0.0 0.0.255.255
R2:
ospf 1 router-id 2.2.2.2
area 0.0.0.1
network 172.16.0.0 0.0.255.255
R3:
ospf 1 router-id 3.3.3.3
area 0.0.0.0
network 172.16.32.1 0.0.0.0
area 0.0.0.1
network 172.16.64.3 0.0.0.0
network 172.16.88.1 0.0.0.0
R5:
ospf 1 router-id 5.5.5.5
area 0.0.0.0
network 172.16.0.0 0.0.255.255
R6:
ospf 1 router-id 6.6.6.6
area 0.0.0.0
network 172.16.32.3 0.0.0.0
network 172.16.48.1 0.0.0.0
area 0.0.0.2
network 172.16.96.1 0.0.0.0
R7:
ospf 1 router-id 7.7.7.7
area 0.0.0.0
network 172.16.32.4 0.0.0.0
network 172.16.56.1 0.0.0.0
area 0.0.0.3
network 172.16.128.1 0.0.0.0
R8:
ospf 1 router-id 8.8.8.8
area 0.0.0.3
network 172.16.0.0 0.0.255.255
R9:
ospf 1 router-id 9.9.9.9
import-route ospf 2
area 0.0.0.3
network 172.16.136.2 0.0.0.0
ospf 2 router-id 9.9.9.9
import-route ospf 1
area 0.0.0.4
network 172.16.160.1 0.0.0.0
network 172.16.168.1 0.0.0.0
R10:
ospf 2 router-id 10.10.10.10
area 0.0.0.4
network 172.16.0.0 0.0.255.255
R11:
ospf 1 router-id 11.11.11.11
area 0.0.0.2
network 172.16.0.0 0.0.255.255
R12:
ospf 1 router-id 12.12.12.12
import-route rip 1
area 0.0.0.2
network 172.16.104.2 0.0.0.0
不规则区域area4
方法:采用OSPF多进程重发布的方式解决重发布问题
R9:
ospf 1 router-id 9.9.9.9
import-route ospf 2
area 0.0.0.3
network 172.16.136.2 0.0.0.0
ospf 2 router-id 9.9.9.9
asbr-summary 172.16.160.0 255.255.224.0
import-route ospf 1
area 0.0.0.4
network 172.16.160.1 0.0.0.0
network 172.16.168.1 0.0.0.0
R10:
ospf 2 router-id 10.10.10.10
area 0.0.0.4
network 172.16.0.0 0.0.255.255
R12:
RIP配置
R12:
rip 1
version 2
network 172.16.0.0
在R12上实现路由过滤
asbr-summary 172.16.160.0 255.255.224.0 not-advertise
R3:
area 0.0.0.1
abr-summary 172.16.32.0 255.255.224.0
2.area2的汇总
R6:
area 0.0.0.2
abr-summary 172.16.96.0 255.255.224.0
R7:
area 0.0.0.3
abr-summary 172.16.128.0 255.255.224.0
域外路由汇总
1、OSPF2进程汇总
R9:
ospf 2
asbr-summary 172.16.160.0 255.255.224.0
2、RIP的汇总
R12:
ospf 1 router-id 12.12.12.12
asbr-summary 172.16.208.0 255.255.240.0 not-advertise
asbr-summary 172.16.192.0 255.255.240.0 not-advertise
特殊区域
1、area1的完全末梢区域
R1:
ospf 1
area 1
stub
R2:
ospf 1
area 1
stub
R3:
ospf 1
area 1
stub no-summary
2、area2、area3的完全NSSA
AREA2:
R6:
ospf 1
area 2
nssa no-summary
R11:
ospf 1
area 2
nssa
R12:
ospf 1
area 2
nssa
AREA3:
R7:
ospf 1
area 3
nssa no-summary
R8:
ospf 1
area 3
nssa
R9:
ospf 1
area 3
nssa
NAT配置
R3:
acl 2000
rule 5 permit source 172.16.0.0 0.0.255.255
int s3/0/0
nat outbound 2000
R6:
acl 2000
rule 5 permit source 172.16.0.0 0.0.255.255
int s4/0/0
nat outbound 2000
R7:
acl 2000
rule 5 permit source 172.16.0.0 0.0.255.255
int s4/0/1
nat outbound 2000