Person类的属性: String name, int age, boolean gender
Person类的方法:
public Person(String name, int age, boolean gender);
public String toString(); //返回"name-age-gender"格式的字符串
public boolean equals(Object obj);//比较name、age、gender,都相同返回true,否则返回false
Student类继承自Person,属性:String stuNo, String clazz
Student类的方法:
//建议使用super复用Person类的相关有参构造函数
public Student(String name, int age, boolean gender, String stuNo, String clazz);
public String toString(); //返回 “Student:person的toString-stuNo-clazz”格式的字符串
public boolean equals(Object obj);//首先调用父类的equals方法,如果返回true,则继续比较stuNo与clazz。
Company类属性:String name
Company类方法:
public Company(String name);
public String toString(); //直接返回name
public boolean equals(Object obj);//name相同返回true
Employee类继承自Person,属性:Company company, double salary
Employee类方法:
//建议使用super复用Person类的相关有参构造函数
public Employee(String name, int age, boolean gender, double salary, Company company);
public String toString(); //返回"Employee:person的toString-company-salary"格式的字符串
public boolean equals(Object obj);//首先调用父类的equals方法,如果返回true。再比较company与salary。
//比较salary属性时,使用DecimalFormat df = new DecimalFormat("#.#");保留1位小数
对Employee的company属性的比较。要考虑传入为null的情况。如果company不为null且传入为null,返回false
对所有String字符类型比较时,也要考虑null情况。
提示:排序可使用Collections.sort;equals方法要考虑周全
创建若干Student对象、Employee对象。
输入s,然后依次输入name age gender stuNo clazz创建Student对象。
输入e,然后依次输入name age gender salary company创建Employee对象。
然后将创建好的对象放入List personList。输入其他字符,则结束创建。
创建说明: 对于String类型,如果为null则不创建对象,而赋值为null。对于company属性,如果为null则赋值为null,否则创建相应的Company对象。
对personList中的元素实现先按照姓名升序排序,姓名相同再按照年龄升序排序。提示:可使用Comparable或Comparator
接受输入,如果输入为exit则return退出程序,否则继续下面步骤。
将personList中的元素按照类型分别放到stuList与empList。注意:不要将两个内容相同的对象放入列表(是否相同是根据equals返回结果进行判定)。
输出字符串stuList,然后输出stuList中的每个对象。
输出字符串empList,然后输出empList中的每个对象。
输入样例:
s zhang 23 false 001 net15
e wang 18 true 3000.51 IBM
s zhang 23 false 001 net15
e bo 25 true 5000.51 IBM
e bo 25 true 5000.52 IBM
e bo 18 true 5000.54 IBM
e tan 25 true 5000.56 IBM
e tan 25 true 5000.51 IBM
s wang 17 false 002 null
s wang 17 false 002 null
e hua 16 false 1000 null
s wang 17 false 002 net16
e hua 16 false 1000 null
e hua 18 false 1234 MicroSoft
!
continue
输出样例:
Employee:bo-18-true-IBM-5000.54
Employee:bo-25-true-IBM-5000.51
Employee:bo-25-true-IBM-5000.52
Employee:hua-16-false-null-1000.0
Employee:hua-16-false-null-1000.0
Employee:hua-18-false-MicroSoft-1234.0
Employee:tan-25-true-IBM-5000.56
Employee:tan-25-true-IBM-5000.51
Student:wang-17-false-002-null
Student:wang-17-false-002-null
Student:wang-17-false-002-net16
Employee:wang-18-true-IBM-3000.51
Student:zhang-23-false-001-net15
Student:zhang-23-false-001-net15
stuList
Student:wang-17-false-002-null
Student:wang-17-false-002-net16
Student:zhang-23-false-001-net15
empList
Employee:bo-18-true-IBM-5000.54
Employee:bo-25-true-IBM-5000.51
Employee:hua-16-false-null-1000.0
Employee:hua-18-false-MicroSoft-1234.0
Employee:tan-25-true-IBM-5000.56
Employee:tan-25-true-IBM-5000.51
Employee:wang-18-true-IBM-3000.51
import java.text.DecimalFormat;
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
List<Person> personList = new ArrayList<>();
List<Student> stuList = new ArrayList<>();
List<Employee> empList = new ArrayList<>();
boolean flag = true;
while (true){
String str = scan.nextLine();
String[] strings = cut(str," ");
if (!strings[0].equals("exit")){
if (flag){
switch (strings[0]){
case "s":
personList.add(new Student(strings[1],Integer.parseInt(strings[2]),Boolean.parseBoolean(strings[3]),strings[4],strings[5]));
break;
case "e":
personList.add(new Employee(strings[1],Integer.parseInt(strings[2]),Boolean.parseBoolean(strings[3]),
Double.parseDouble(strings[4]),strings[5] == "null"? null: new Company(strings[5])));
break;
default:
flag = false;
//排序
personList.sort(new Comparator<Person>() {
@Override
public int compare(Person o1, Person o2) {
int sort = o1.name.compareTo(o2.name);
if(sort == 0) return o1.age - o2.age;
return sort;
}
});
//分裝
for (int i=0;i<personList.size();i++){
Person person = personList.get(i);
if (person instanceof Student) {
if (stuList.indexOf(person) == -1) stuList.add((Student) person);
} else {
if (empList.indexOf(person) == -1) empList.add((Employee) person);
}
}
//輸出
for(int i=0;i<personList.size();i++){
System.out.println(personList.get(i));
}
}
} else {
System.out.println("stuList");
for(Person p:stuList) System.out.println(p);
System.out.println("empList");
for(Person p:empList) System.out.println(p);
}
}else return;
}
}
private static String[] cut(String str, String s) {
String[] strings = str.split(s);
for (int i=0;i<strings.length;i++){
if (strings[i].equals("null")) strings[i] = null;
}
return strings;
}
}
abstract class Person{
String name;
int age;
boolean gender;
public Person(String name, int age, boolean gender) {
this.name = name;
this.age = age;
this.gender = gender;
}
@Override
public String toString() {
return this.name + "-" + this.age + "-" + this.gender;
}
@Override
public boolean equals(Object obj) {
if (this == obj) return true;
Person that = (Person) obj;
return (this.name == that.name|| this.name != null && this.name.equals(that.name))
&& this.age == that.age && this.gender == that.gender;
}
}
class Student extends Person{
private String stuNo;
private String clazz;
public String getStuNo() {
return stuNo;
}
public void setStuNo(String stuNo) {
this.stuNo = stuNo;
}
public String getClazz() {
return clazz;
}
public void setClazz(String clazz) {
this.clazz = clazz;
}
public Student(String name, int age, boolean gender, String stuNo, String clazz) {
super(name, age, gender);
this.setStuNo(stuNo);
this.setClazz(clazz);
}
@Override
public String toString() {
return "Student:" + super.toString() + "-" + this.getStuNo() + "-" + this.getClazz();
}
@Override
public boolean equals(Object obj){
if (super.equals(obj)){
Student that = (Student) obj;
if((that.stuNo == this.stuNo || that.stuNo != null && that.stuNo.equals(this.stuNo))
&& (that.clazz == this.clazz || that.clazz != null && that.clazz.equals(this.clazz)))
return true;
}
return false;
}
}
class Company{
public String name;
public Company(String name) {
this.name = name;
}
@Override
public String toString() {
return name;
}
@Override
public boolean equals(Object obj) {
if (this == obj) return true;
if (obj == null || getClass() != obj.getClass()) return false;
Company company = (Company) obj;
if(company.name == this.name || company.name != null && company.name.equals(this.name))
return true;
return false;
}
}
class Employee extends Person{
private Company company;
private double salary;
public Company getCompany() {
return company;
}
public void setCompany(Company company) {
this.company = company;
}
public double getSalary() {
return salary;
}
public void setSalary(double salary) {
this.salary = salary;
}
public Employee(String name, int age, boolean gender,double salary,Company company) {
super(name, age, gender);
this.setCompany(company);
this.setSalary(salary);
}
@Override
public String toString() {
return "Employee:" + super.toString() + "-" + this.getCompany() +"-" + this.getSalary();
}
@Override
public boolean equals(Object obj) {
if (super.equals(obj)){
Employee that = (Employee)obj;
DecimalFormat df = new DecimalFormat("#.#");
return (this.company == that.company||this.company != null && this.company.equals(that.company))
&& df.format(this.salary).equals(df.format(that.salary));
}
return false;
}
}