网络工程——专业实习训练(拓扑搭建5)

掌握路由策略控制路由信息条目。

路由控制的方式

        1.控制路由的发布:通过路由策略对发布的路由进行过滤,只发布满足条件的路由

        2.控制路由的接收:通过路由策略对接收的路由进行过滤,只接收满足条件的路由

        3.控制路由的引入:通过路由策略控制从其他路由协议引入的路由条目,只有满足条件的路由才会被引入

 掌握生成树协议STP、RSTP、MSTP的基本原理及配置方法。

        STP(Spanning Tree Protocol)是生成树协议的英文缩写,可应用于计算机网络中树形拓扑结构建立,主要作用是防止网桥网络中的冗余链路形成环路工作。

掌握虚拟网关协议VRRP的基本原理及配置方法。

VRRP的基本原理

        VRRP即虚拟路由器冗余协议。

        利用VRRP,一组路由器协同工作,但只有一个处于Master状态,处于该状态的路由器承担实际的数据流量转发任务。在一个VRRP组内的多个路由器接口公用一个虚拟IP地址,该地址被作为局域网所有主机的缺省网管地址。

        VRRP决定哪个路由器是Master,Master路由器负责接受发送至网管的数据包并进行转发,以及响应PC对于其网管IP地址的ARP请求。

        Backup路由器侦听Master路由器的状态,并在Msater路由器发生故障时,接替其工作,从而保证业务流量的平滑切换。

 掌握链路聚合LACP静态的基本原理及配置方法。

        链路聚合是把两台设备之间的多条物理链路聚合在一起,当做一条逻辑链路来使用,以实现出/入流量吞吐量在各成员端口的负荷分担。

        采用链路聚合技术可以在不进行硬件升级的条件下,通过将多个物理接口捆绑为一个逻辑接口,来达到增加链路带宽的目的。在实现增大带宽目的的同时,链路聚合采用备份链路的机制,可以有效的提高设备之间链路的可靠性。

        链路聚合包含两种模式:手动负载均衡模式和静态LACP(Link Aggregation Control Protocol)模式。

掌握NAT的原理和配置方法。

        NAT:对1P数据报文中的IP地址进行转换,是一种在现网中被广泛部署的技术,一般部署在网络出口设备,例如路由器或防火墙上。
        通过私有地址的使用结合NAT技术,可以有效节约公网IPv4地址。

掌握PPPoe拨号配置。

拓扑图

网络工程——专业实习训练(拓扑搭建5)_第1张图片

配置命令 

AR1
acl number 2000  
 rule 5 deny source 192.168.10.220 0 
 rule 6 deny source 192.168.20.252 0 
 rule 10 permit source 192.168.20.0 0.0.0.255 
 rule 15 permit source 192.168.10.0 0.0.0.255 
 rule 20 permit 
acl number 2001  
 rule 5 permit 
 rule 10 permit source 192.168.0.0 0.0.255.255 
#
acl number 3000  
 rule 5 deny tcp source 192.168.10.0 0.0.0.255 destination 172.16.1.2 0 destinat
ion-port eq ftp 
 rule 10 deny tcp source 192.168.20.0 0.0.0.255 destination 172.16.1.2 0 destina
tion-port eq ftp 
 rule 15 permit tcp source 192.168.30.0 0.0.0.255 destination 172.16.1.2 0 desti
nation-port eq ftp 
 rule 20 deny tcp source 192.168.30.0 0.0.0.255 destination 172.16.1.2 0 destina
tion-port eq www 
 rule 25 permit tcp destination-port eq www 
#
ip pool vlan40
 gateway-list 192.168.40.254 
 network 192.168.40.0 mask 255.255.255.0 
 dns-list 202.1.1.1 
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
interface Dialer1
 link-protocol ppp
 ppp chap user liuwei
 ppp chap password cipher %$%$0.q9Tr-^t@g)bpIiRu]P,/xb%$%$
 ip address ppp-negotiate
 dialer user liuwei
 dialer bundle 1
 nat outbound 2001
#
interface Dialer2
 link-protocol ppp
 ppp chap user liuwei2
 ppp chap password cipher %$%$O5,AD0ouU)O#]t=yTfpG,.]~%$%$
 ip address ppp-negotiate
 dialer user liuwei2
 dialer bundle 2
 nat outbound 2001
#
interface GigabitEthernet0/0/0
 ip address 192.168.11.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 192.168.13.1 255.255.255.0 
 dhcp select global
#
interface GigabitEthernet0/0/2
 ip address 192.168.31.1 255.255.255.0 
#
interface GigabitEthernet6/0/0
 ip address 172.16.1.1 255.255.255.0 
 traffic-filter outbound acl 3000
#
interface GigabitEthernet6/0/1
 pppoe-client dial-bundle-number 1 
#
interface GigabitEthernet6/0/2
 pppoe-client dial-bundle-number 2 
#
interface GigabitEthernet6/0/3
 ip address 192.168.17.1 255.255.255.0 
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.0 
#
ospf 1 router-id 1.1.1.1 
 default-route-advertise always
 area 0.0.0.0 
  network 1.1.1.0 0.0.0.255 
  network 172.16.1.0 0.0.0.255 
  network 192.168.11.0 0.0.0.255 
  network 192.168.13.0 0.0.0.255 
  network 192.168.17.0 0.0.0.255 
#
rip 1
#
ip route-static 0.0.0.0 0.0.0.0 Dialer1
ip route-static 0.0.0.0 0.0.0.0 Dialer2

AR3
ip pool vlan30
 gateway-list 192.168.30.254 
 network 192.168.30.0 mask 255.255.255.0 
 excluded-ip-address 192.168.30.253 
 dns-list 6.6.6.6 
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher huawei
 local-user admin service-type http
#
interface GigabitEthernet0/0/0
 ip address 192.168.13.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/1.30
 dot1q termination vid 30
 ip address 192.168.30.254 255.255.255.0 
 arp broadcast enable
 dhcp select global
#
interface GigabitEthernet0/0/1.40
 dot1q termination vid 40
 ip address 192.168.40.254 255.255.255.0 
 arp broadcast enable
 dhcp select relay
 dhcp relay server-ip 192.168.13.1
#
interface GigabitEthernet0/0/2
 ip address 192.168.31.2 255.255.255.0 
#
interface GigabitEthernet4/0/0
 ip address 192.168.37.1 255.255.255.0 
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.0 
#
ospf 1 router-id 3.3.3.3 
 import-route rip 1
 area 0.0.0.0 
  network 3.3.3.0 0.0.0.255 
  network 192.168.13.0 0.0.0.255 
#
rip 1
 undo summary
 version 2
 network 192.168.30.0
 network 192.168.40.0
 network 192.168.37.0
 import-route ospf 1
#
ip route-static 0.0.0.0 0.0.0.0 192.168.13.1

SW1
stp region-configuration
 region-name huawei
 instance 1 vlan 10 30
 instance 2 vlan 20 40
 active region-configuration
#
interface Vlanif10
 ip address 192.168.10.254 255.255.255.0
 dhcp select interface
 dhcp server excluded-ip-address 192.168.10.221 192.168.10.253
 dhcp server dns-list 114.114.114.114
#
interface Vlanif11
 ip address 192.168.11.2 255.255.255.0
#
interface Vlanif30
 ip address 192.168.30.254 255.255.255.0
 dhcp select interface
 dhcp server dns-list 8.8.8.8
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
 mode lacp-static
 max active-linknumber 2
#
interface Eth-Trunk2
 mode lacp-static
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 11
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20 30 40
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 10 20 30 40
#
interface GigabitEthernet0/0/5
 eth-trunk 1
#
interface GigabitEthernet0/0/6
 eth-trunk 1
#
interface GigabitEthernet0/0/7
 eth-trunk 1
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.0
#
ospf 1 router-id 2.2.2.2
 area 0.0.0.0
  network 192.168.11.0 0.0.0.255
  network 2.2.2.0 0.0.0.255
 area 0.0.0.1
  network 192.168.10.0 0.0.0.255
  network 192.168.20.0 0.0.0.255
  network 192.168.30.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 192.168.11.1

SW8
vlan batch 10 17 20 30 40
#
stp instance 0 priority 4096
stp instance 1 root secondary
stp instance 2 root primary
#
stp region-configuration
 region-name huawei
 instance 1 vlan 10 30
 instance 2 vlan 20 40
 active region-configuration
#
interface Vlanif17
 ip address 192.168.17.2 255.255.255.0
#
interface Vlanif20
 ip address 192.168.20.254 255.255.255.0
 dhcp select interface
 dhcp server dns-list 114.114.114.114
#
interface Vlanif40
 ip address 192.168.40.254 255.255.255.0
 dhcp select interface
 dhcp server dns-list 8.8.8.8
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
 mode lacp-static
 max active-linknumber 2
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 17
#
interface GigabitEthernet0/0/3
 eth-trunk 1
#
interface GigabitEthernet0/0/4
 eth-trunk 1
#
interface GigabitEthernet0/0/5
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/6
 port link-type trunk
 port trunk allow-pass vlan 10 20 30 40
#
interface GigabitEthernet0/0/7
 eth-trunk 1
#
interface GigabitEthernet0/0/8
 port link-type trunk
 port trunk allow-pass vlan 10 20 30 40
interface LoopBack0
 ip address 4.4.4.4 255.255.255.0
#
ospf 1 router-id 4.4.4.4
 area 0.0.0.0
  network 192.168.17.0 0.0.0.255
  network 4.4.4.0 0.0.0.255
 area 0.0.0.1
  network 192.168.10.0 0.0.0.255
  network 192.168.20.0 0.0.0.255
  network 192.168.40.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 192.168.17.1

SW3
vlan batch 10 20 30 40
#
stp region-configuration
 region-name huawei
 instance 1 vlan 10 30
 instance 2 vlan 20 40
 active region-configuration
#
interface Ethernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/3
 port link-type access
 port default vlan 10
 stp edged-port enable
#
interface Ethernet0/0/4
 port link-type access
 port default vlan 20
#
interface Ethernet0/0/5
 port link-type access
 port default vlan 30

SW4
vlan batch 10 15 to 16 20 30 40
#
stp region-configuration
 region-name huawei
 instance 1 vlan 10 30
 instance 2 vlan 20 40
 active region-configuration
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 40
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface Ethernet0/0/3
 port link-type access
 port default vlan 10
#
interface Ethernet0/0/4
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

SW6
vlan batch 30 40
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 30
#
interface Ethernet0/0/2
 port link-type access
 port default vlan 40
#
interface Ethernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 30 40
#
ip route-static 0.0.0.0 0.0.0.0 192.168.31.2

SW7
vlan batch 37 100 to 101
#
interface Vlanif37
 ip address 192.168.37.2 255.255.255.0
#
interface Vlanif100
 ip address 192.168.100.254 255.255.255.0
 dhcp select interface
 dhcp server dns-list 114.114.114.114
#
interface Vlanif101
 ip address 192.168.101.254 255.255.255.0
 dhcp select interface
 dhcp server dns-list 8.8.8.8
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 37
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 100
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 101
#
rip 1
 undo summary
 version 2
 network 192.168.100.0
 network 192.168.101.0
 network 192.168.37.0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.37.1

AR4
ip pool pppoe2
 gateway-list 201.1.1.254 
 network 201.1.1.0 mask 255.255.255.0 
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher huawei
 local-user admin service-type http
 local-user liuwei2 password cipher huawei
 local-user liuwei2 service-type ppp
#
interface Virtual-Template2
 ppp authentication-mode chap 
 remote address pool pppoe2
 ip address 201.1.1.254 255.255.255.0 
#
interface GigabitEthernet0/0/0
 pppoe-server bind Virtual-Template 2
#
interface GigabitEthernet0/0/1
 ip address 212.1.1.1 255.255.255.0 
#
interface LoopBack0
 ip address 9.9.9.9 255.255.255.0 
#
rip 1
 undo summary
 version 2
 network 9.0.0.0
 network 201.1.1.0
 network 200.1.1.0
 network 212.1.1.0

AR6
ip pool pppoe
 gateway-list 200.1.1.254 
 network 200.1.1.0 mask 255.255.255.0 
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher huawei
 local-user admin service-type http
 local-user liuwei password cipher huawei
 local-user liuwei service-type ppp
#
interface Virtual-Template1
 ppp authentication-mode chap 
 remote address pool pppoe
 ip address 200.1.1.254 255.255.255.0 
#
interface GigabitEthernet0/0/0
 pppoe-server bind Virtual-Template 1
#
interface GigabitEthernet0/0/2
 ip address 212.1.1.2 255.255.255.0 
#
interface LoopBack0
 ip address 8.8.8.8 255.255.255.0 
#
rip 1
 undo summary
 version 2
 network 8.0.0.0
 network 212.1.1.0
 network 200.1.1.0
 network 202.1.1.0

你可能感兴趣的:(ensp网络实训报告,网络,网络协议,学习,测试工具,云计算)