MUX VLAN虚拟局域网内实现二层隔离或通信,

MUX VLAN(multiplex vlan)通过vlan进行网络资源控制机制。能实现vlan内端口二层隔离,减少vlan的使用量。
MUX VLAN的划分:
主vlan(principal vlan):可以与mux vlan内所有vlan进行通信。
隔离型从vlan(separate vlan):只能和principal vlan进行通信。和其他类型的vlan完全隔离,separate vlan内部也完全隔离。
互通型从vlan(group vlan): 可以和principal vlan进行通信,在同一group vlan内的用户也可以相互通信,但是不能和其他group vlan或者separate vlan内的用户通信的vlan。
配置
MUX VLAN虚拟局域网内实现二层隔离或通信,_第1张图片

如图左边group vlan vlan10 20 可以vlan内相互访问也可以访问 principal vlan 40。但是不同vlan不可以访问。
右边separate vlan 30,vlan内也不可以相互访问,各端口二层隔离。

mux vlan 配置如下。

lsw2

sysname lsw2 
vlan batch 10 20 30 40
vlan 10 
description abc1 vlan
vlan 20
description abc2 vlan 
vlan 30
description  bbc1 vlan
vlan 40
description  aaa1 vlan
mux-vlan                                          //将vlan40设置为principal vlan
subordinate separate 30                  //将vlan30设置为separate vlan
subordinate group 10 20                 //将vlan10 20 设置为group vlan

interface g 0/0/2
port link-type trunk
port trunk allow-pass vlan 10 20 30 40
interface g 0/0/3
port link-type trunk
port trunk allow-pass vlan 10 20 30 40
interface g 0/0/4
port link-type access
port default vlan 40
port mux-vlan enable

lsw3

sysname lsw3 
vlan batch 10 20 30 40
vlan 10 
description abc1 vlan
vlan 20
description abc2 vlan 
vlan 30
description  bbc1 vlan
vlan 40
description  aaa1 vlan
mux-vlan
subordinate separate 30
subordinate group 10 20

interface g 0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20 30 40
interface e 0/0/1
port link-type access
port default vlan 10
port mux-vlan enable
interface e 0/0/2
port link-type access
port default vlan 20
port mu-vlan enable
interface e 0/0/3
port link-type access
port default vlan 20
port mu-vlan enable

lsw4

sysname lsw4
vlan batch 10 20 30 40
vlan 10 
description abc1 vlan
vlan 20
description abc2 vlan 
vlan 30
description  bbc1 vlan
vlan 40
description  aaa1 vlan
mux-vlan
subordinate separate 30
subordinate group 10 20

int g 0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20 30 40
int e 0/0/1
interface e 0/0/1
port link-type access
port default vlan 30
port mux-vlan enable
int e 0/0/2
port link-type access
port default vlan 30
port mux-vlan enable

vlan内单独端口隔离

int e 0/0/1
port link-type access
port default vlan 10
port-isolate-enable group 1

端口安全,(端口绑定mac)

大体分3种
安全动态mac地址, 安全静态mac地址, sticky mac地址
int e 0/0/1
port link-type access
port default vlan 10
port-security enable
port-security mac-address sticky
port-security mac-address sticky 2342-2fff-ffff vlan 10

你可能感兴趣的:(网络协议)