HDU 2120 Ice_cream's world I【并查集】

解题思路:给出n对点的关系,求构成多少个环,如果对于点x和点y,它们本身就有一堵墙,即为它们本身就相连,如果find(x)=find(y),说明它们的根节点相同,它们之间肯定有直接或间接的相连,即形成环

样例的示意图

HDU 2120 Ice_cream's world I【并查集】

共3个环

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 642    Accepted Submission(s): 371

Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 
Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 
Output
Output the maximum number of ACMers who will be awarded. One answer one line.
 
Sample Input
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 
Sample Output
3
 
#include<stdio.h>

#include<string.h>

 int pre[10005],a[10005];

 int find( int root)

{

	if(root!=pre[root])

	pre[root]=find(pre[root]);

	return pre[root];

}

void unionroot( int root1,int root2)

{

	 int x,y;

	x=find(root1);

	y=find(root2);

	if(x!=y)

	pre[x]=y;

}



int main()

{

	int root1,root2,x,y,i,n,m,tmp;

	while(scanf("%d %d",&n,&m)!=EOF)

	{

		tmp=0;

		for(i=0;i<=10005;i++)

		pre[i]=i;

		while(m--)

		{

			scanf("%d %d",&root1,&root2);

			x=find(root1);

			y=find(root2);

			if(x==y)

			tmp++;

			unionroot(x,y);

		}

		

		printf("%d\n",tmp);

		

	}

}

  

你可能感兴趣的:(HDU)