试题 算法训练 首字母变大写

问题描述
  对一个字符串中的所有单词,如果单词的首字母不是大写字母,则把单词的首字母变成大写字母。在字符串中,单词之间通过空白符分隔,空白符包括:空格(’ ‘)、制表符(’\t’)、回车符(’\r’)、换行符(’\n’)
输入格式
  输入一行:待处理的字符串(长度小于80)
输出格式
  输出一行:转换后的字符串。
样例输入
if so, you already have a google account. you can sign in on the right.
样例输出
If So, You Already Have A Google Account. You Can Sign In On The Right.
资源限制
时间限制:1.0s 内存限制:512.0MB

代码块

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		
		String s = sc.nextLine();
		String sp[] = s.split(" ");
		String res = "";
		for(int i = 0; i < sp.length; i++){
			if(sp[i].charAt(0)>='a'&&sp[i].charAt(0)<='z'){
				res += (sp[i].charAt(0)+"").toUpperCase();
				res += sp[i].substring(1,sp[i].length())+" ";
			}else{
				res += sp[i];
			}
		}
		
		System.out.println(res);
	}
}

评测结果
在这里插入图片描述

你可能感兴趣的:(AL-蓝桥杯,字符串,java)