L1-023 输出GPLT-java

L1-023 输出GPLT-java_第1张图片

 

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

思路

设置一个GPLT的计数器
然后遍历的时候每次对计数器的个数减一
import java.io.*;

public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
        String str = bf.readLine().toUpperCase();
        //定义一个计数器,分别计算GPLT的个数
        int[] count = new int[4];
        for (int i = 0; i < str.length(); i++) {
            if(str.charAt(i) == 'G'){
                count[0]++;
            } else if(str.charAt(i) == 'P'){
                count[1]++;
            } else if(str.charAt(i) == 'L'){
                count[2]++;
            } else if(str.charAt(i) == 'T'){
                count[3]++;
            }
        }
        //找出四个字母中个数最多的字母
        int max = Math.max(Math.max(count[0], count[1]), Math.max(count[2], count[3]));
        for (int i = 0; i < max; i++) {
            if(count[0]--> 0){
                System.out.print("G");
            }
            if(count[1]--> 0){
                System.out.print("P");
            }
            if(count[2]--> 0){
                System.out.print("L");
            }
            if(count[3]--> 0){
                System.out.print("T");
            }
        }
    }
}

 

 

你可能感兴趣的:(pta,java,算法,开发语言)