HDU1394 Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5950    Accepted Submission(s): 3625


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

 

Output
For each case, output the minimum inversion number on a single line.
 

 

Sample Input
10 1 3 6 9 0 8 5 7 4 2
 

 

Sample Output
16
 

 

Author
CHEN, Gaoli
 

 

Source
 

Ignatius.L

 
 
 
#include<iostream>

#include<cstdio>

#include<cstring>



using namespace std;



const int N=5010;



#define L(rt) (rt<<1)

#define R(rt) (rt<<1|1)



struct Tree{

    int l,r;

    int sum;

}tree[N<<2];



void PushUp(int rt){

    tree[rt].sum=tree[L(rt)].sum+tree[R(rt)].sum;

}



void build(int L,int R,int rt){

    tree[rt].l=L;

    tree[rt].r=R;

    if(tree[rt].l==tree[rt].r){

        tree[rt].sum=0;

        return ;

    }

    int mid=(L+R)>>1;

    build(L,mid,L(rt));

    build(mid+1,R,R(rt));

    PushUp(rt);

}



void update(int id,int rt){

    if(tree[rt].l==tree[rt].r){

        tree[rt].sum++;

        return ;

    }

    int mid=(tree[rt].l+tree[rt].r)>>1;

    if(id<=mid)

        update(id,L(rt));

    else if(id>=mid+1)

        update(id,R(rt));

    PushUp(rt);

}



int query(int L,int R,int rt){

    if(L<=tree[rt].l && tree[rt].r<=R){

        return tree[rt].sum;

    }

    int mid=(tree[rt].l+tree[rt].r)>>1;

    int ans=0;

    if(R<=mid)

        ans+=query(L,R,L(rt));

    else if(L>=mid+1)

        ans+=query(L,R,R(rt));

    else{

        ans+=query(L,mid,L(rt));

        ans+=query(mid+1,R,R(rt));

    }

    return ans;

}



int num[N];



int main(){



    //freopen("input.txt","r",stdin);



    int n;

    while(~scanf("%d",&n)){

        build(0,n-1,1);

        int tmp=0;

        for(int i=0;i<n;i++){

            scanf("%d",&num[i]);

            tmp+=query(num[i],n-1,1);

            update(num[i],1);

        }

        int res=tmp;

        for(int i=0;i<n;i++){

            tmp+=(n-1-num[i])-num[i];

            res=min(res,tmp);

        }

        printf("%d\n",res);

    }

    return 0;

}

 

 

 

你可能感兴趣的:(version)