数据结构之 线性表--链表的逆置

数据结构实验之链表三:链表的逆置

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

输入

输入多个整数,以-1作为结束标志。

输出

输出逆置后的单链表数据。

示例输入

12 56 4 6 55 15 33 62 -1

示例输出

62 33 15 55 6 4 56 12

#include <iostream>

#include <string>

#include <string.h>

#include <stdio.h>

#include <algorithm>

#include <algorithm>



using namespace std;



struct node

{

    int data;

    struct node *next;

};



int main()

{

    int n;

    int len=0;



    struct node *head, *p;

    head=new struct node;

    head->next=NULL;



    while(cin>>n && n!=-1 )

    {

        p=new struct node;

        p->data = n;

        p->next = head->next;

        head->next=p;

        len++;

    }

    for(int i=1; i<=len; i++)

    {

        if(i==1)

        {

            cout<<head->next->data;

        }

        else

        {

            cout<<" "<<head->next->data;

        }

        head=head->next;

    }

    cout<<"\n";

    return 0;

}

 



你可能感兴趣的:(数据结构)