HDU 4861(多校)1001 Couple doubi

Problem Description
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
 

Input
Multiply Test Cases. 
In the first line there are two Integers k and p(1<k,p<2^31).
 

Output
For each line, output an integer, as described above.
 

Sample Input
   
   
2 3 20 3
 

Sample Output
   
   
YES NO
 

Source
 

Recommend
We have carefully selected several similar problems for you:   4871  4870  4869  4868  4867 
 
没听过什么费马定理,就仅仅知道这:

卧槽,就这样勉强写的,哎,说多了都是泪。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

long long  k,p;
int main()
{
    while(~scanf("%I64d%I64d",&k,&p))
    {
        int s=0;
        if(p==2)
        {
           if(((k+1)/2%2))
              cout<<"YES"<<endl;
           else
              cout<<"NO"<<endl;
           continue;
        }
        s=k/(p-1);
        if(s%2)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

事实上仅仅要这样。。。
HDU 4861(多校)1001 Couple doubi_第1张图片
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

long long  k,p;
int main()
{
    while(~scanf("%I64d%I64d",&k,&p))
    {
        int s=k/(p-1);
        if(s%2)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

我小学没毕业,干只是那些高中生。。

你可能感兴趣的:(HDU)