[HDU 1789] Doing Homework again

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6925    Accepted Submission(s): 4124


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 
Output
For each test case, you should output the smallest total reduced score, one line per test case.
 
Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 
Sample Output
0 3 5
 

注意不同于doing homework

贪心,将作业按分值排序,将每个作业安排到截止时间,如果被占了,就继续往前找空的时间,找不到就扣分。

为什么能这样? 因为要求扣分最少,而每一门作业的时间都是1天完成,所以放弃一个分值小的总比放弃一个分值大的要好。

#include <iostream>

#include <algorithm>

#include <cstring>

using namespace std;

#define N 1010

struct course

{

    int deadtime;

    int score;

    bool operator <(const course &t)const

    {

        if(score!=t.score) return score>t.score;

        return deadtime<t.deadtime;

    }

}s[N];

int main()

{

    int vis[N];

    int T,n,i,j;

    scanf("%d",&T);

    while(T--)

    {

        scanf("%d",&n);

        memset(vis,0,sizeof(vis));

        for(i=1;i<=n;i++)

        {

            scanf("%d",&s[i].deadtime);

        }

        for(i=1;i<=n;i++)

        {

            scanf("%d",&s[i].score);

        }

        sort(s+1,s+n+1);

        int ans=0;

        for(i=1;i<=n;i++)

        {

            for(j=s[i].deadtime;j>=1;j--)

            {

                if(!vis[j])

                {

                    vis[j]=1;

                    break;

                }

            }

            if(j==0) ans+=s[i].score;

        }

        cout<<ans<<endl;

    }

    return 0;

}

 

你可能感兴趣的:(home)