hdu1231 最大连续子序列

最大连续子序列

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17172    Accepted Submission(s): 7551


Problem Description
给定K个整数的序列{ N1, N2, ..., NK },其任意连续子序列可表示为{ Ni, Ni+1, ..., 
Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个, 
例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和 
为20。 
在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该 
子序列的第一个和最后一个元素。
 

Input
测试输入包含若干测试用例,每个测试用例占2行,第1行给出正整数K( < 10000 ),第2行给出K个整数,中间用空格分隔。当K为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最大和、最大连续子序列的第一个和最后一个元 
素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。 
 

Sample Input
  
   
   
   
   
6 -2 11 -4 13 -5 -2 10 -10 1 2 3 4 -5 -23 3 7 -21 6 5 -8 3 2 5 0 1 10 3 -1 -5 -2 3 -1 0 -2 0
 

Sample Output
  
   
   
   
   
20 11 13 10 1 4 10 3 5 10 10 10 0 -1 -2 0 0 0
Hint
Hint
Huge input, scanf is recommended.

//============================================================================
// Name        : hdu1231.cpp
// Author      : vit
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>
using namespace std;


int main() {
	int k, sum, final, temp,start, end, first,s ,e;
	while (scanf("%d",&k)) {//大量数据输入输出的时候试用scanf将速度很快。。。
		if(k == 0)
			break;
		scanf("%d",&temp);
		first = temp;
		k--;
		final = s = e = sum = start = end = temp;

		while (k--) {
			scanf("%d",&temp);
			if(sum < 0 && temp < 0)
				continue;
			if (sum + temp < temp) { //sum < 0
				sum = temp;
				start = temp;
				end = temp;
			} else {
				sum += temp;
			}
			//cout << sum  << " " << temp << endl;
			if (sum > final) {
				final = sum;
				s = start;
				e = temp;
			}
		}

		if (final >= 0) {
			cout << final << " " << s << " " << e << endl;
		} else
			cout << '0' << " " << first << " " << temp << endl;
	}
	return 0;
}



你可能感兴趣的:(编程,c,算法,dp)