hdu1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9673    Accepted Submission(s): 4423


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
   
   
   
   
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
   
   
   
   
6 -1
 



//============================================================================
// Name        : KMP_hdu1711.cpp
// Author      : vit
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>
using namespace std;

int t, no;
int i, j;
int m, n;
int a[1000001];
int b[10001];
int next[10001];

void GetNext() {//next数组最小为-1
	j = 0;
	i = -1;
	next[0] = -1;
	while (j < m) {
		if (i == -1 || b[i] == b[j]) {
			i++, j++;
			next[j] = i;
		} else {
			i = next[i];
		}
	}
}

int KMPIndex() {
	GetNext();
	i = 0;
	j = 0;
	while (i < n && j < m) {
		if (a[i] == b[j] || j == -1) {
			i++;
			j++;
		} else {
			j = next[j];
		}
		if (j == m) {
			return i - m + 1;
		}
	}
	return -1;
}

int main() {
	cin >> t;
	while (t--) {
		scanf("%d %d", &n, &m);
		for (i = 0; i < n; i++) {
			scanf("%d", &a[i]);
		}
		for (i = 0; i < m; i++) {
			scanf("%d", &b[i]);
		}
		cout << KMPIndex() << endl;
	}
	return 0;
}


你可能感兴趣的:(编程,c,算法,编程语言,KMP)