hdu1097 A hard puzzle

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27417    Accepted Submission(s): 9761


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
  
   
   
   
   
7 66 8 800
 

Sample Output
  
   
   
   
   
9 6
 


//============================================================================
// Name        : Math_hdu1097.cpp
// Author      : vit
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>

using namespace std;

int nu[10] = { 1, 1, 4, 4, 2, 1, 1, 4, 4, 2 }; //找规律

int main() {
	int a, b;

	while (cin >> a >> b) {
		a = a % 10;
		if (nu[a] == 1) {
			cout << a << endl;
			continue;
		}
		b = b % nu[a];
		if (a == 4) {
			switch (b) {
			case 0:
				cout << '6' << endl;
				break;
			case 1:
				cout << '4' << endl;
				break;
			default:
				break;
			}
		} else if (a == 9) {
			switch (b) {
			case 0:
				cout << '1' << endl;
				break;
			case 1:
				cout << '9' << endl;
				break;
			default:
				break;
			}
		} else if (a == 2) {
			switch (b) {
			case 0:
				cout << '6' << endl;
				break;
			case 1:
				cout << '2' << endl;
				break;
			case 2:
				cout << '4' << endl;
				break;
			case 3:
				cout << '8' << endl;
				break;
			default:
				break;
			}
		} else if (a == 3) {
			switch (b) {
			case 0:
				cout << '1' << endl;
				break;
			case 1:
				cout << '3' << endl;
				break;
			case 2:
				cout << '9' << endl;
				break;
			case 3:
				cout << '7' << endl;
				break;
			default:
				break;
			}
		} else if (a == 8) {
			switch (b) {
			case 0:
				cout << '6' << endl;
				break;
			case 1:
				cout << '8' << endl;
				break;
			case 2:
				cout << '4' << endl;
				break;
			case 3:
				cout << '2' << endl;
				break;
			default:
				break;
			}
		} else if (a == 7) {
			switch (b) {
			case 0:
				cout << '1' << endl;
				break;
			case 1:
				cout << '7' << endl;
				break;
			case 2:
				cout << '9' << endl;
				break;
			case 3:
				cout << '3' << endl;
				break;
			default:
				break;
			}
		}

	}

	return 0;
}


你可能感兴趣的:(编程,C++,c,算法,编程语言)