谁动了我的网络系列 之eigrp 选路 等价 负载 均衡非等价负载均衡等 ..










如图    最终的结果贴出来了   中间的show  ip route  拓扑啥的没贴    
R2 的s0/1、 s0/2、s0/3  和 R 3  的 s0/0、s0/2、s0/3 相连接    图上不是很清楚标注一下 

有点疑问的是 当做完了 R1、R2 手工修改带宽影响选路后    再做 r1和r2的 非等价负载均衡没效果    把手工 修改的带宽     conft-if#no ban  512  之后 非等价负载均衡就起来了   
不多说了  上show  run   


r1#show run
Building configuration...

Current configuration : 1602 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback10
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback20
 ip address 172.16.2.1 255.255.255.0
!
interface Loopback30
 ip address 172.16.3.1 255.255.255.0
!
interface Loopback40
 ip address 172.16.4.1 255.255.255.0
!
interface Loopback50
 ip address 172.16.5.1 255.255.255.0
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 ip summary-address eigrp 100 172.16.0.0 255.255.248.0 5
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown 
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 10.10.10.1 255.255.255.0
 ip summary-address eigrp 100 172.16.0.0 255.255.248.0 5
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
!
router eigrp 100
 variance 2
 network 1.1.1.0 0.0.0.255
 network 10.10.10.0 0.0.0.255
 network 12.0.0.0
 network 172.16.0.0
 no auto-summary
!
router eigrp 1000
 auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
!
!         
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end

r1# 


r2#show run 
Building configuration...

Current configuration : 1247 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 serial restart-delay 0
!         
interface Serial0/1
 ip address 23.23.23.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/2
 ip address 23.23.24.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/3
 ip address 23.23.25.2 255.255.255.0
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 10.10.10.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
!
router eigrp 100
 variance 2
 network 2.2.2.0 0.0.0.255
 network 10.10.10.0 0.0.0.255
 network 10.0.0.0
 network 12.0.0.0
 network 23.0.0.0
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!         
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

r2#  



r3#show run
Building configuration...

Current configuration : 1162 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface Serial0/0
 ip address 23.23.23.3 255.255.255.0
 serial restart-delay 0
!         
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 ip address 23.23.24.3 255.255.255.0
 serial restart-delay 0
!
interface Serial0/3
 ip address 23.23.25.3 255.255.255.0
 serial restart-delay 0
!
interface Ethernet1/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!         
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
!
router eigrp 100
 network 3.3.3.0 0.0.0.255
 network 3.0.0.0
 network 23.0.0.0
 no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
!         
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

r3#  

本文出自 “荒原” 博客,谢绝转载!

你可能感兴趣的:(负载均衡,职场,休闲,EIGRP)