Number Sequence

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).



Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.



Output
For each test case, print the value of f(n) on a single line.



Sample Input
1 1 3
1 2 10
0 0 0


Sample Output
2
5

#include<stdio.h>
int main()
{    
   int a,b,n,i,x1,x2,x;
   while(scanf("%d%d%d",&a,&b,&n),a||b||n)
     {   
          x1=x2=1;
          n%=49;
  for(i=3;i<=n;i++)
  {
  x=(x2*a+x1*b)%7 ;  
  x1=x2;
  x2=x;
         }  
  if(n==1||n==2)printf("%d\n",1);
  else printf("%d\n",x);
     }
   return 0;
}

你可能感兴趣的:(F#)