NYOJ1979_black and red

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 17059   Accepted: 8995

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

Japan 2004 Domestic

#include<stdio.h>
#include<string.h>
char a[25][25];
int visit[25][25];
int find(int i,int j)
{
 if(visit[i][j]==0)
  return 0;
 else
 visit[i][j]=0;
 return 1+find(i+1,j)+find(i-1,j)+find(i,j+1)+find(i,j-1);
}
int main()
{
 int w,h;
 int i,j,x,y;
 while(scanf("%d%d",&w,&h)!=EOF&&(w||h))
 {
 
  memset(a,'#',sizeof(a));
  memset(visit,0,sizeof(visit));
    for(i=1;i<=h;i++)
  { getchar();
   for(j=1;j<=w;j++)
    scanf("%c",&a[i][j]);
  }
  for(i=0;i<h+2;i++)
   for(j=0;j<w+2;j++)
   { if(a[i][j]=='@')
    {
     x=j;
     y=i;
     a[i][j]='.';
    }
    if(a[i][j]=='.')
     visit[i][j]=1;
   }
  printf("%d\n",find(y,x));
 }
 return 0;
}

 

你可能感兴趣的:(red,black)