今天接着来
基本配置依旧以附件形式发上来
步骤1:全网配置EIGRP实现互通。
实现目的:R1可以看到22、33、77开头路由各7条,44开头路由15条144开头路由各16条。
R1:router eigrp 100
redistribute static
offset-list off in 10 Serial0/0
network 1.1.1.1 0.0.0.0
network 12.1.1.1 0.0.0.0
network 14.1.1.1 0.0.0.0
network 17.1.1.1 0.0.0.0
no auto-summary
R2:router eigrp 100
network 2.2.2.2 0.0.0.0
network 12.1.1.2 0.0.0.0
network 22.1.0.0 0.0.7.255
network 23.1.1.2 0.0.0.0
no auto-summary
R3:router eigrp 100
network 3.3.3.3 0.0.0.0
network 23.1.1.3 0.0.0.0
network 33.1.0.0 0.0.7.255
network 37.1.1.3 0.0.0.0
no auto-summary
R4:router eigrp 100
network 4.4.4.4 0.0.0.0
network 14.1.1.4 0.0.0.0
network 44.1.0.0 0.0.15.255
network 144.1.16.0 0.0.15.255
no auto-summary
R7:router eigrp 100
network 7.7.7.7 0.0.0.0
network 17.1.1.7 0.0.0.0
network 37.1.1.7 0.0.0.0
network 77.1.0.0 0.0.7.255
no auto-summary
结果:
步骤2:在R2、3、4、7配置汇总,向邻居发送汇总路由,R2汇总时同时发送一条22.1.7.0/24的明细路由到邻居。
R2:
ip access-list standard leak
permit 22.1.7.0 0.0.0.255 发送到邻居的明细路由
interface Serial0/0
ip summary-address eigrp 100 22.1.0.0 255.255.248.0 5 leak-map leak 手工汇总
interface Serial0/1
ip summary-address eigrp 100 22.1.0.0 255.255.248.0 5 leak-map leak
R3:
interface Serial0/0
ip summary-address eigrp 100 33.1.0.0 255.255.248.0 5
interface Serial0/1
ip summary-address eigrp 100 33.1.0.0 255.255.248.0 5
R4:
interface FastEthernet0/0
ip summary-address eigrp 100 144.1.16.0 255.255.240.0
ip summary-address eigrp 100 44.1.0.0 255.255.240.0
R7:
interface Serial0/1
ip summary-address eigrp 100 77.1.0.0 255.255.248.0
步骤3:使用offset list实现路径控制。网络在正常情况下R7到达除了R3以外的网络,流量从链路1通过,R3到达除了R7以为的网络流量有链路2通过。
R3:
ip access-list standard off
permit 4.4.4.4
permit 0.0.0.0
permit 1.1.1.1
permit 44.1.0.0 0.0.15.255
permit 144.1.16.0 0.0.15.255
permit 14.1.1.0 0.0.0.255
router eigrp 100
offset-list off in 100 Serial0/1
R2:
ip access-list standard off
permit 7.7.7.7
permit 77.1.0.0 0.0.7.255
router eigrp 100
offset-list off in 100 Serial0/1
R1:
ip access-list standard off
permit 3.3.3.3
permit 33.1.0.0 0.0.7.255
router eigrp 100
offset-list off in 10 Serial0/1
R7:
ip access-list standard off
permit 2.2.2.2
permit 22.1.0.0 0.0.7.255
router eigrp 100
offset-list off in 100 Serial0/1
步骤4:
配置EIGRP自动分发默认路由
R1配置到R4lo口的默认路由,再配置EIGRP通告默认路由,保证R2、3、7有默认路由能ping通R4lo口,不允许默认路由通告给R4。
R1:
ip access-list standard norouter
deny 0.0.0.0
permit any
router eigrp 100
redistribute static
distribute-list norouter out FastEthernet0/0
步骤5:配置R3、7作为eigrp stup路由器,只发生直连和汇总路由,当链路1或2任意一条失败都能与全网通信。
R3:
ip access-list standard tor2
permit 7.7.7.7
permit 77.1.0.0
ip access-list standard tor7
permit any
route-map stub permit 10
match ip address tor7
set interface Serial0/0
route-map stub permit 20
match ip address tor2
set interface Serial0/1
router eigrp 100
eigrp stub connected summary leak-map stub
R7:
ip access-list standard tor1
permit 3.3.3.3
permit 33.1.0.0 0.0.7.255
ip access-list standard tor3
permit any
route-map stub permit 10
match ip address tor1
set interface Serial0/0
!
route-map stub permit 20
match ip address tor3
set interface Serial0/1
router eigrp 100
eigrp stub connected summary leak-map stub