当技术停留在NP阶段的时候,练习一下CCIE的版本,关于更多的IE版本,我已经上传到下载了。个人觉得CCIE就是CCNP的综合知识,当你敲完所有的版本时,技术肯定有飞跃。
实验拓扑及题目要求见附件:
r1#show run
Building configuration...
Current configuration : 1416 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.1.1 255.255.255.255
!
interface Loopback1
no ip address
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Ethernet0/1
ip address 32.32.12.1 255.255.255.0
ip ospf priority 0
full-duplex
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
no ip address
shutdown
half-duplex
!
interface Serial1/0
ip address 32.32.11.1 255.255.255.248
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 255
serial restart-delay 0
frame-relay map ip 32.32.11.3 113 broadcast
frame-relay map ip 32.32.11.4 114 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 32.0.0.0 0.255.255.255 area 0
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
r2#show run
Building configuration...
Current configuration : 1718 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.2.2 255.255.255.255
!
interface Loopback1
ip address 150.4.32.1 255.255.255.0
!
interface Ethernet0/0
ip address 150.1.32.1 255.255.255.0
full-duplex
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
no ip address
shutdown
half-duplex
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 32.32.13.2 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
ip ospf dead-interval 60
serial restart-delay 0
frame-relay map ip 32.32.13.1 215 broadcast
no frame-relay inverse-arp
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
redistribute rip metric-type 1 subnets
network 32.0.0.0 0.255.255.255 area 25
!
router rip
version 2
passive-interface Ethernet0/0
passive-interface Loopback1
network 150.1.0.0
network 150.4.0.0
neighbor 150.1.32.254
distribute-list FROM-BB1 in Ethernet0/0
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
ip access-list standard FROM-BB1
permit 199.172.5.0 0.0.8.0
permit 199.172.10.0 0.0.4.0
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
r3#show ru
*Mar 1 02:51:50.659: %SYS-5-CONFIG_I: Configured from console by console
r3#show run
Building configuration...
Current configuration : 1766 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.3.3 255.255.255.255
!
interface Ethernet0/0
ip address 32.32.10.3 255.255.255.0
full-duplex
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
no ip address
shutdown
half-duplex
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 32.32.11.3 255.255.255.248
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 32.32.11.1 311 broadcast
frame-relay map ip 32.32.11.4 311 broadcast
no frame-relay inverse-arp
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 32
redistribute ospf 1 metric 2000 100 255 1 1500
network 32.32.3.0 0.0.0.255
network 32.32.10.0 0.0.0.255
network 32.32.11.0 0.0.0.255
no auto-summary
!
router ospf 1
log-adjacency-changes
redistribute eigrp 32 subnets route-map from-eigrp
network 32.32.3.3 0.0.0.0 area 0
network 32.32.11.3 0.0.0.0 area 0
!
ip http server
no ip http secure-server
!
!
!
!
ip access-list standard r6-lb
permit 32.32.6.6
!
route-map from-eigrp permit 10
match ip address r6-lb
set metric 19
!
route-map from-eigrp permit 20
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
r4# sho run
Building configuration...
Current configuration : 1677 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.4.4 255.255.255.255
!
interface Ethernet0/0
ip address 32.32.10.4 255.255.255.0
full-duplex
!
interface Ethernet0/1
ip address 32.32.14.4 255.255.255.0
full-duplex
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
no ip address
shutdown
half-duplex
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 32.32.11.4 255.255.255.248
encapsulation frame-relay
ip ospf network broadcast
ip ospf priority 0
serial restart-delay 0
frame-relay map ip 32.32.11.1 411 broadcast
frame-relay map ip 32.32.11.3 411 broadcast
no frame-relay inverse-arp
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 32
redistribute connected route-map CONN
redistribute ospf 1 metric 2000 100 1 255 1500
network 32.32.4.0 0.0.0.255
network 32.32.10.0 0.0.0.255
no auto-summary
!
router ospf 1
log-adjacency-changes
redistribute eigrp 32 subnets
network 32.32.4.4 0.0.0.0 area 0
network 32.32.11.4 0.0.0.0 area 0
!
ip http server
no ip http secure-server
!
!
!
!
route-map CONN permit 10
match interface Ethernet0/1 Serial1/1
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
r5#show run
Building configuration...
Current configuration : 1409 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.5.5 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Ethernet0/1
ip address 32.32.12.5 255.255.255.0
ip ospf priority 0
full-duplex
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
no ip address
shutdown
half-duplex
!
interface Serial1/0
ip address 32.32.13.1 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
ip ospf dead-interval 60
serial restart-delay 0
frame-relay map ip 32.32.13.2 512 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 32.32.5.5 0.0.0.0 area 0
network 32.32.12.5 0.0.0.0 area 0
network 32.32.13.1 0.0.0.0 area 25
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
r6#show run
Building configuration...
Current configuration : 1733 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.6.6 255.255.255.255
!
interface Ethernet0/0
ip address 32.32.9.6 255.255.255.0
full-duplex
!
interface Ethernet0/1
no ip address
full-duplex
!
interface Ethernet0/1.50
encapsulation dot1Q 50
ip address 150.2.32.1 255.255.255.0
!
interface Ethernet0/1.70
encapsulation dot1Q 70
ip address 150.3.32.1 255.255.255.0
ip summary-address eigrp 100 32.32.0.0 255.255.0.0 5
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
no ip address
shutdown
half-duplex
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 32
passive-interface Ethernet0/1.70
passive-interface Loopback0
network 32.0.0.0
network 150.3.0.0
no auto-summary
!
router eigrp 100
redistribute eigrp 32
network 150.3.0.0
distribute-list TO-BB3 out Ethernet0/1.70
distribute-list FROM-BB3 in Ethernet0/1.70
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
ip prefix-list FROM-BB3 seq 5 permit 198.0.0.0/8 le 32
!
ip access-list standard FROM-BB3
ip access-list standard TO-BB3
permit 32.32.0.0
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
sw1#show run
Building configuration...
Current configuration : 1773 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sw1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.7.7 255.255.255.255
!
interface Port-channel2
switchport mode trunk
!
interface Port-channel3
switchport mode trunk
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
switchport access vlan 40
!
interface FastEthernet1/3
switchport access vlan 20
!
interface FastEthernet1/4
switchport access vlan 20
!
interface FastEthernet1/5
!
interface FastEthernet1/6
no switchport
ip address 32.32.9.7 255.255.255.0
!
interface FastEthernet1/7
!
interface FastEthernet1/8
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet1/9
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet1/10
switchport access vlan 40
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet1/14
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan20
ip address 32.32.10.7 255.255.255.0
!
router eigrp 32
network 32.0.0.0
auto-summary
!
router ospf 1
log-adjacency-changes
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
sw2#show run
Building configuration...
*Mar 1 02:53:43.867: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1756 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sw2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.8.8 255.255.255.255
!
interface Port-channel2
switchport mode trunk
!
interface Port-channel6
switchport mode trunk
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
switchport access vlan 30
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
switchport access vlan 60
!
interface FastEthernet1/5
switchport access vlan 30
!
interface FastEthernet1/6
switchport mode trunk
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
switchport access vlan 50
!
interface FastEthernet1/11
switchport mode trunk
channel-group 6 mode on
!
interface FastEthernet1/12
switchport mode trunk
channel-group 6 mode on
!
interface FastEthernet1/13
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet1/14
switchport mode trunk
channel-group 2 mode on
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan30
ip address 32.32.12.8 255.255.255.0
ip ospf priority 255
!
router ospf 1
log-adjacency-changes
network 32.0.0.0 0.255.255.255 area 0
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
sw3>en
sw3#show run
Building configuration...
Current configuration : 1625 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sw3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.9.9 255.255.255.255
!
interface Port-channel3
switchport mode trunk
!
interface Port-channel6
switchport mode trunk
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet1/9
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet1/10
switchport access vlan 70
!
interface FastEthernet1/11
switchport mode trunk
channel-group 6 mode on
!
interface FastEthernet1/12
switchport mode trunk
channel-group 6 mode on
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan60
ip address 32.32.14.9 255.255.255.0
!
!
!
ip http server
no ip http secure-server
!
mac-address-table static c000.0cdc.0000 interface FastEthernet1/9 vlan 1
!
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
sw3#show int lo0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 32.32.9.9/32
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
sw3#en
sw3#show run
Building configuration...
Current configuration : 1625 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sw3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 32.32.9.9 255.255.255.255
!
interface Port-channel3
switchport mode trunk
!
interface Port-channel6
switchport mode trunk
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet1/9
switchport mode trunk
channel-group 3 mode on
!
interface FastEthernet1/10
switchport access vlan 70
!
interface FastEthernet1/11
switchport mode trunk
channel-group 6 mode on
!
interface FastEthernet1/12
switchport mode trunk
channel-group 6 mode on
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan60
ip address 32.32.14.9 255.255.255.0
!
!
!
ip http server
no ip http secure-server
!
mac-address-table static c000.0cdc.0000 interface FastEthernet1/9 vlan 1
!
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end